Sonoma server issue

Forum / NoMachine for Mac / Sonoma server issue

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #45521

    I upgraded my M1 Mac mini to Sonoma and can no longer successfully connect to it. The server reports a connection, but the client screen is blank. The server continues to report connections after I stop trying as well.


    Same here, but I have a m2 pro. NoMachine was working on Ventura, but since upgrading to Sonoma I get blank screen on connecting



    it looks like after update the permissions for Accessibilty and Screen Recording are not handled properly. May you please try removing NoMachine from both lists and then restart NoMachine (you can do it from terminal with sudo /etc/NX/nxserver --restart) and follow the prompts that should direct you to enabling both permissions?


    NX> 162 Disabled service: nxd.

    NX> 596 ERROR: Cannot create file ‘/Applications/’. Error is ‘Operation not permitted’.

    NX> 500 ERROR: Cannot stop service: nxserver.

    NX> 595 Cannot open file ‘/Applications/’ for writing: Operation not permitted.

    NX> 500 ERROR: Last operation failed.

    $ sudo /etc/NX/nxserver –restart

    NX> 162 Service: nxd already disabled.

    $ sudo /etc/NX/nxserver –stop

    NX> 596 ERROR: Cannot create file ‘/Applications/’. Error is ”.

    NX> 500 ERROR: Cannot stop service: nxserver.

    $ sudo /etc/NX/nxserver –start

    NX> 111 The server is configured to accept connections.

    NX> 111 NoMachine services are shut down.

    NX> 111 Run ‘nxserver –startup’ to start up the services.


    I got no prompts. I’ll try and do it manually from system settings. And them maybe reinstall?


    $ sudo /etc/NX/nxserver –startup

    NX> 111 New connections to NoMachine server are enabled.

    NX> 161 Service: nxserver already running.

    NX> 161 Service: nxnode already running.

    NX> 161 Enabled service: nxd.


    I was able to disable and re-enable screen recording, but not sure what to do about accessibility. Now I get this:

    The remote host ‘’ refused to establish a network connection on port ‘4000’. Please verify that NoMachine is correctly installed and listening on the port where you are trying to connect, and that incoming traffic is not being blocked by a firewall or NAT.

    I’ll reinstall.



    Okay, that worked! I had to manually kill NoMachine from the terminal before I could uninstall it: $ sudo killall nxserver

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.