Sound not working (MacMini M1)

Forum / NoMachine for Mac / Sound not working (MacMini M1)


Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #32953

    Hello together,

    First of all, thanks for the great product, I use NoMachine for years and it’s working perfectly.
    Unfortunately, I have an issue, where I need your help.

    I have the following setup:

    MacMini M1 (MacOS 11.2.3)
    NoMachine 7.4.1

    Debian 10.9
    NoMachine 7.4.1

    I can’t get the sound forwarding working.
    I play a YouTube video and the sound isn’t forwarded to the client.
    You can see, that there is a sound playing on the server, but the client is quiet.

    When I use a Windows machine as client, the sound is working!

    So, the Linux VDA seems not to be the problem.

    I checked a few logfiles, enabled the debug logging for nxnode and found the following entries:
    7566 21763 14:27:59 546.922 AudioSystemUtilities: WARNING! Could not get ID for kernel control.
    7566 21763 14:27:59 553.896 AudioSystemDeviceHandler: WARNING! Could not retrieve id for device name NoMachine Audio Adapter.
    7566 21763 14:27:59 553.919 AudioSystemDeviceHandler: WARNING! Initialization failed.
    Warning: AudioSystemDeviceHandler: Error level is 2.
    7566 21763 14:27:59 553.931 AudioSystemUtilities: WARNING! Could not access to device handler for reading.

    This is, where I need your help.

    Please tell me, how to get this error fixed and the sound working on my Mac.

    Thanks in advance!



    M1 Macs audio is not supported yet if you will use it as server, but used as client audio forwarding it works.
    Those logs are from the server-side.

    Please, check if you granted mic permission to NM in settings.
    If not, grant it and restart the server from the terminal:
    /etc/NX/nxserver --restart



    thanks for the reply.

    The logs are from the client-side, under my user’s profile.

    The NoMachine App isn’t appearing under the microphone section in the permission settings.

    I also tried to reinstall the whole app, but MacOS isn’t asking for the permission.

    It only asks for permissions regarding assistance features, which I granted.




    Before you do it manually, just checked, it definitely asks permission when trying to play something in the NM session. You should give permission and restart nxserver.


    Hi again,

    Yes, it’s on the same machine but those logs are related only when you use your Mac as a host.
    It should ask permission, we are gonna try to reproduce, but for you, you can give to NM mic permission manually:

    Open terminal and run:
    sudo sqlite3 '/Users/nomachine/Library/Application Support/'
    enter your password.
    insert into access VALUES('kTCCServiceMicrophone','com.nomachine.nxdock',0,2,2,1,NULL,NULL,NULL,'UNUSED',NULL,0,1610447022);

    Close sqlite with Ctrl+d

    and restart nxserver:
    sudo /etc/NX/nxserver --restart

    then please check.


    Thanks a lot for your feedback.

    Giving the permissions manually, worked (had to grant full-disk access to the terminal, first).

    Now, the sounds are playing, as wanted.

    And NoMachine is appearing as permitted for accessing the microphone.

    Thanks again for solving my issue and have a nice day!


    Hi Turbo_2021,

    we are glad to hear that it worked!

    We’ve opened a Trouble Report: TR04S10212. You can sign up to receive notification of a fix when it’s available. Thanks for reporting.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.