Strange rendering of “ff”, “fi”, “fl” sequences

Forum / NoMachine for Linux / Strange rendering of “ff”, “fi”, “fl” sequences

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #35518
    Dennis H


    I am facing a strange problem where certain character sequences are not rendered correctly. For example, I am at a console window using a fixed width font. I type “fi”, but this is rendered as a narrow “fi” that takes up one cell. At the same time the cursor has moved 2 cells over. So if I type “fififi” those letters will display in 3 cells, while the cursor will be 3 cells too far to the right. Among the f’s, these combinations create this behavior:


    It seems like ‘f’ is introducing some sort of multi-character sequence that is treated specially, but I can’t find what settings affect this. I am seeing the problem using Konsole and the Kate editor (in KDE). Within IntelliJ the “fi” renders correctly.

    My setup:

    Client – Windows 10 – NM 7.6.2, free version

    Server –

    cat /proc/version
    Linux version 3.10.0-1160.6.1.el7.x86_64 ( (gcc version 4.8.5 20150623 (Red Hat 4.8.5-44) (GCC) ) #1 SMP Tue Nov 17 13:59:11 UTC 2020

    (Note that this server is a VM hosted in Platform 9)

    /etc/NX/nxserver –version
    NoMachine – Version 7.6.2

    Thank you in advance for any advice.

    Dennis H

    I at first thought this was a NoMachine problem because when I logged into this system using Putty the problem did not occur. This is actually not a NoMachine problem, it is an issue using the Monospace font. Here’s some background:

    I worked around it by using the Courier font.



    Hi Dennis,

    Great that you found a workaround. Thank you for letting us know! 😉

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.