Suddenly unable to control/interact with physical display

Forum / NoMachine for Linux / Suddenly unable to control/interact with physical display

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #14303

    Good day!

    I’ve been using NoMachine for many years now. Have been running it fine on both Ubuntu 14.04|16.04, and Fedora 23|24.

    Yesterday on my Fedora24 workstation, I had to restart. (dun,dun,dun)

    Nah everything came back fine. Finished up my day on Friday without issues.

    However the next day, I needed to connect to the system remotely. All status quo; I connect from Ubuntu 16.04 client, to the PhysicalDisplay and resume the session. (I’ve done this hundreds of times… nothing has changed except that ONE reboot of the Fedora24 host system).

    The typical workflow is:

    • leave Fedora24 on (NoMachine server is always running)
    • when desired, remotely connect to physical display from Ubuntu 16.04 (always worked in the past)
    • display is presented, I either press <ENTER> or <CLICK>’n'<DRAG>’up to rollup the GDM login screen
    • login, boom in

    But today

    • remotely connect to Fedora24
    • screen is display as usual
    • BUT: I can’t control or interact with the remote host system!! aaahghrg

    I’ve verified that the configuration is still sane. (nothing changed)


    # Allow the user to connect to the physical desktop:
    # 1: Enabled. Each user can request to connect to the
    #    physical desktop.
    # 0: Disabled. Connections to the physical desktop are
    #    forbidden.
    PhysicalDesktopSharing 1

    # Set the interaction level for the session connected to the physical
    # desktop:
    # 0: View-only. The session is connected to the desktop in
    #    view-only mode, i.e. the user can’t interact with the
    #    physical desktop.
    # 1: Restricted. User connected to the physical desktop can
    #    interact with the desktop except for resize operations.
    # 2: Interactive. User connected to the physical desktop has
    #    full interaction with the desktop.
    PhysicalDesktopMode 2

    Tried restarting the nxserver


    /usr/NX/bin/nxserver –restart


    Viewed/monitored the logs as I initiate a connection (trying to look for errors/warnings/msgs that might explain why I’m not “allowed” to interact with the remote display…) but nothing obvious is glaring to me which would explain anything.


    Has anyone else had this problem?

    Any ideas what could be broken?



    to investigate further we would need you to reproduce the problem, collect logs and send them to forum[at]nomachine[dot]com.

    You can find instructions about debug and collecting logs here:


    Unable to reproduce the issue after restart of the system.

    I /suspect/, actally, that there was a video driver hang. Since I wasn’t able to be at the physical display at the time of this issue, the problem /appeared/ (manifested) itself as a NoMachine issue, but as soon as I got to my physical desktop it was clear the display system was hung.

    -> Recently newer versions of the Linux kernel, which Fedora has been releasing, are having issues with nVidia nouveau driver.

    Since switching to the proprietary driver the system has been more stable and I’ve not had a problem remotely connecting thus far.

    For now, let’s consider this as “not reproducible” or “solved” — I’ll post back if it happens again 😉


    Ok, thanks for letting us know 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.