Taskbars missing in NoMachine

Forum / NoMachine for Windows / Taskbars missing in NoMachine

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #15490

    I use NoMachine to connect from Windows to a remote Linux machine to produce a virtual display. Recently, my upper and lower taskbars have disappeared. The main problem is that, if I minimize a window, I now have no way of retrieving it, since it is typically iconized in the upper taskbar.

    The problem occurs regardless of what computer I log in from. I’ve tried the following things, with no success:

    • Changed the display options to see if these taskbars were simply off the screen.
    • Delete the .nx directory in my home directory.
    • Uninstall and reinstall NoMachine.
    • Searched for the problem on Google, NoMachine forums, and StackOverflow.

    I’ve had this problem before, and I believe it resolved itself after a number of days, but I’d rather not wait and hope for something to change. Has anyone heard of this problem before?

    I use the free version of NoMachine to connect.  The connection information says the following: Server version: 4.2.22 with player 5.3.9; Server OS: Fedora release 23 (Twenty Three).

    Alternately, if the primary problem has no clear solution, is there any way of retrieving minimized windows within NoMachine without using the taskbar (e.g. can I access those windows through a keyboard shortcut or the right-click menu)?

    I’ve attached an image of my workspace. You can see the outer Windows taskbars, but typically there are two additional taskbars.


    That looks an issue with a corrupted Gnome configuration rather than NoMachine itself. I’d suggest to search log files ~/.xsession-errors and /var/log/messages for Gnome-related messages. Then a reset of desktop config files for the affected users could help. Configurations are generally stored in hidden folders and files under the home directory. Try to stop any instance of Gnome for the affected user, kill any remaining gnome process that wasn’t terminated, then move all the configurations in a backup directory:
    cd ~
    mkdir config-backup
    mv .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails .config .compiz config-backup

    Then check if problem is solved.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.