Terminal Server Node VD Session Unresponsive 30-60 Minutes After Connecting

Forum / NoMachine Terminal Server Products / Terminal Server Node VD Session Unresponsive 30-60 Minutes After Connecting

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #8373


    I am currently testing a terminal server node environment with Enterprise Server Evaluation v4.6.16, running on a VM on CentOS 6.6 as the server host. The server host is managing two VM nodes that are running Terminal Server Node Evaluation v4.6.16, also on CentOS 6.6. I am using NoMachine Windows client v4.6.16 on a Windows 7 machine, to connect to the server host. The environment works as expected, with the server host providing GNOME virtual desktops that are load-balanced across the two nodes. However, after being connected to a node for about 30-60 minutes, with occasional inactivity, I lose mouse and keyboard control to everything on the desktop except for the currently active window. I also only have basic functionality within the window. No copy. No paste. No right-click menu. Closing the remaining active window results in a silhouette of the window with 100% loss of functionality. When this happens, I have to disconnect the session and wait for the server host to release it and then create a new connection. I currently have two other people testing using NoMachine 4.6.16 client on Windows 7 machines, and they have not experienced this problem so far. For me, the problem makes NoMachine unusable and is a show-stopper. Has anyone else experienced this problem?

    I have attached client and server debug logs. Hopefully those will be useful.


    Issues similar to yours show up when a modifier key became stuck (because the “key released” event was caught by another application).

    When problem occurs, try to press and release once all the modifiers (Shift, Ctrl, Alt, for both left and right hand) and verify if behavior came back to normal.


    Thanks for your response and sorry for my delayed follow-up.

    The problem just occurred again this morning. I tried what you had suggested but that didn’t work. Any other suggestions?


    I read your original report again:

    I lose mouse and keyboard control to everything on the desktop except for the currently active window

    It is possible the window manager grabbed keyboard and mouse and failed to release them. On the next time, try ro restart the window manager in the remote desktop:


    $ metacity --replace


    I also suggest to try the new NoMachine 5 release.


    • This reply was modified 8 years, 8 months ago by graywolf.

    I have tried restarting the window manager with the command that you suggested, as well as update the client to v5, and neither have worked, unfortunately. I am stumped at this point.

    I appreciate your help.


    I am now using a different Windows 7 machine with NoMachine client v5 and am having the same problem. Could this be a profile issue?


    May I suggest to reset your custom configuration?

    I noticed OpenNX created some files in the .nx folder. Please uninstall OpenNX at first.

    Then clean up your configuration: move the %USERPROFILE%\.nx directory to a backup folder, let’s say %USERPROFILE%\dotnx (you could like to access your old configuration files later).

    Do the same thing for the $HOME/.nx folder on the remote nodes.

    Finally reset your Gnome configuration on NoMachine nodes:

    1. Be sure you have no desktop session running on the nodes (neither remote nor local).
    2. Reach nodes through SSH
    3. Create a backup folder for Gnome configuration files: $ mkdir oldconfig
    4. Move current config files to backup: $ mv .gnome .gnome2 .gconf .gconfd .metacity oldconfig
    5. Run NoMachine to create a remote Gnome session: configuration will be recreated.



    Please note that the forums are for NoMachine software issues only (version 4 or 5). If you have any questions about 3.5.0 software or NX derivatives, these need to be directed via the website and won’t be published here. Thanks!


    Thanks again for your response and your suggestions.

    I have forced the use of xfce4 in the /usr/NX/etc/node.cfg file on both test nodes, as this will be the preferred DE to use if/when this goes live. Incidentally, I no longer have the keyboard/mouse input problem that I was having before. It looks like my issue was linked to gnome, and seems to suggest that it’s specifically a gnome profile problem.

    I tried to follow your suggested steps to move the .gnome config files, but I actually do not have any .gnome config files in my $HOME/.nx folder. The home directory is on a file server that is mounted through cifs. I assume that the config files should still be stored there, regardless of it’s location, but perhaps I’m wrong. Could they be stored elsewhere?


    Sorry, my instructions were misleading. Search for Gnome config files and folders in directory $HOME, not $HOME/.nx.


Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.