Text display issue on Mac M1

Forum / NoMachine for Mac / Text display issue on Mac M1


Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #41071


    I have a Mac M1 with Mac OS Monterey version 12.6. Since about a month all texts disappeared from the NoMachine window screens leaving only icon visible. Please find attached a screenshot. I installed the last version 8.1.2 but still have the exact same issue. Any idea?

    Best regards,


    Hi Adam. It looks like your client can’t access the fonts database on your Mac. Can you determine what happened when the client stopped working correctly? Did you update NoMachine, upgrade the OS, installed some 3rd party apps that could affect Mac standard behaviors?

    You could check if the font chooser lets you select anything. Click the Settings button under NoMachine logo, select the second icon in the left column (Player), and the second icon in the right column (Appearance). Once there, click the first button you see on the right column and try to select a different font, or let me know if the chooser is empty as well.



    Thanks for you reply. Please find attached what I can see when I try to select/change the font.


    I tried to reproduce on different machines but without success this problem. It looks that there are some issues with access to the fonts. I would recommend that possibly you try to clear and rebuild macOS font database.

    sudo atsutil databases -remove
    sudo atsutil databases -removeUser
    sudo reboot

    If that does not help, please check if the same problem is present when using another user, and it would be good to verify if in system logs there are information about font problems.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.