The "New desktop" button is disabled

Forum / NoMachine for Linux / The "New desktop" button is disabled

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #5963

    I followed steps in to try to create a virtual desktop. I can log in, but no desktop available and the “New desktop” button in Fig 5 of that webpage on my client machine is disabled. What’s the matter?

    The remote machine is the Amazon EC2 Red Hat t2.micro instance, the local machine is ubuntu 14.04 LTS, both are 64 bit. The software installed on the remote and client side are both the latest. /usr/NX/bin/nxserver is started on the remote machine.

    Attached is the screenshot.


    Which product did you install on the server? Remember Workstation, Terminal Server, Cloud Server and Enterprise Server all offer the virtual desktop functionality (point 1 in the how-to). If you are using the free version on the server side, you might want to consult this how-to for headless servers:


    Hi, Britgirl, Thank you for your reply. I don’t know what product is installed on the EC2 instance. I downloaded the nomachine_4.4.6_7_x86_64.rpm from, which seems to be the only choice for Linux. Then I ran rpm -i nomachine_4.4.6_7_x86_64.rpm to install it on the EC2 instance. The results returned from /usr/NX/bin/nxserver –status are as follows:

    NX> 161 Enabled service: nxserver.
    NX> 162 Cannot find X servers running on this machine.
    NX> 162 Connections to the physical display are not possible.
    NX> 161 Enabled service: nxd.

    I read the webpage You know what? Yes, there are a lot of articles in internet, but they are all TOO OLD, including this one. Things are changing all the time drastically in Linux. To be specific, the very first command of that article “sudo yum install xorg-x11-server-Xvfb” doesn’t work. I was prompted:

    Loaded plugins: aliases, amazon-id, changelog, kabi, langpacks, rhui-lb, tmprepo, verify, versionlock
    Loading support for Red Hat kernel ABI
    No package xorg-x11-server-Xvfb available.
    Error: Nothing to do

    So, could you please run the instructions again in Amazon EC2 instance yourself and update that webpage accordingly? Today is Jan 22, 2015. The RedHat used in EC2 is version 7 (codename: Maipo), not 6 any more.

    I’m using t2.micro instance type, it is in free tier (and therefore crippled).




    It was last updated in December 2014 but I will ask our dev team to check it again to make sure nothing major has changed in the past month that the article doesn’t document. Bear in mind that the article gives general guidelines for some of the most popular distributions. As you yourself said things are changing all the time drastically in Linux, and each of the hundreds of variants are all different. We’ll check against Red Hat 7 and update the article accordingly.


    Thanks for the reply. When checking, please note that the remote environment is Amazon EC2 Red Hat 7 t2.micro instance. one can have that environment in no more than 5 minutes and at no cost. For your reference, following are the results returned from “sudo yum group list” in the instance.

    Loaded plugins: aliases, amazon-id, changelog, kabi, langpacks, rhui-lb, tmprepo, verify, versionlock
    Loading support for Red Hat kernel ABI
    Installed environment groups:
    Server with GUI
    Available environment groups:
    Minimal Install
    Infrastructure Server
    File and Print Server
    Basic Web Server
    Virtualization Host
    Installed groups:
    Compatibility Libraries
    Development Tools
    Graphical Administration Tools
    System Administration Tools
    System Management
    Available Groups:
    Console Internet Tools
    Legacy UNIX Compatibility
    Scientific Support
    Security Tools
    Smart Card Support

    Looking forward to a feedback from the dev team.


    Hello zzzhhh,

    Problem isn’t related to NoMachine software but to RedHat. Instruction of installation Xvfb (“sudo yum install xorg-x11-server-Xvfb”) is correct. You can find the answer for your issue here: or by enabling rhel-7-desktop-optional-beta-rpms repository.

    We will check specifically against the RH t2.micro instance and make sure the article is updated.


    Please check the updated article here:

    To install Xvfb on Amazon EC2 Red Hat t2.micro you should enable rhui-REGION-rhel-server-optional repository by running:

    $ sudo subscription-manager repos –enable rhui-REGION-rhel-server-optional

    or set it manually in /etc/yum.repos.d/redhat-rhui.repo

    Amazon EC2 Red Hat t2.micro you should enable

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.