The sound on the server is broken

Forum / NoMachine for Linux / The sound on the server is broken

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #44600
    lumer1020
    Participant

    Good afternoon!

    After the first connection via NoMachine to the server on Ubuntu 22.04, the sound has disappeared completely (I connect from Windows 11). At the same time the sound will be in the NoMachine application in Windows (i.e. if I turn on the video on the server, the sound will play only through the NoMachine application).

    Reinstalling alsa, NoMachine and other things does not give any results.

    Really need your help!

    Reinstalling Ubuntu is not an option.

    #44610
    Britgirl
    Participant
    #44624
    lumer1020
    Participant

    No, unfortunately not.

    The problem is that there is no sound after disabling the session in NoMachine

    It all started after the first connection.

    I suspect I’m experiencing the same problem

    NoMachine disables sound permanently on server (Ubuntu 22.04)

     

    #44627
    lumer1020
    Participant

    /var/lib/alsa/asound.state doesn’t look healthy

    #44677
    kubaszym1
    Participant

    Hi,

    NoMachine mutes the audio on the server by default. You can unmute in session settings if you want. I assume the main issue is that it stays muted even if client disconnects. It can mean two things: either our muting/unmuting script didn’t work on your machine or it wasn’t called at all while closing session. Testers tried to repeat your issue but they couldn’t. I also tried to reproduce because I have ubuntu 22 as well, but everything works fine for me. Our script uses amixer, so you can try the commands below to check if it works on your machine:

    amixer -c 0 set Master playback 0% mute
    amixer -c 0 set Master playback 100% unmute

    You can also enable debug logs in server settings. On the server side, open NoMachine and go to Settings->Server–>Status->Server logs.

    Regards,

    Kuba

     

     

     

    #44696
    lumer1020
    Participant

    It looked like a plan, but unfortunately it didn’t work 🙁

    Attachments:
    #44728
    lumer1020
    Participant

    Do you have any other suggestions?

    What does this have to do with server logs?

    #44730
    kubaszym1
    Participant

    Hi,

    Which sound server do you use? Pulseaudio or pipewire? If you have pipewire, you can check this file: /usr/NX/etc/node.cfg. The parameter “AudioInterface” should be set to “pipewire” or “pulseaudio” respectively. If it’s not set in the right way, you can manually change and restart the server. Maybe this will help.

    Regards,

    Kuba

    #44734
    lumer1020
    Participant

    pulseaudio is already installed, I did this at the very beginning in my first post – all the points from a similar article. I updated NoMachine to 8.6 (server and client) – this did not solve the problem.

    #44741
    Britgirl
    Participant

    We’ve not been able to reproduce the problem and so we will need the logs from the server. This was not made clear earlier.

    To enable and extract the logs from the server side follow the document here:

    https://kb.nomachine.com/DT07S00243

    Once debug is enabled, you should connect server and  then disconnect. You can also click the mute button a few times to check what happens to unmuting during the session.

    Send logs file to forum[at]nomachine[dot]com.

    #44783
    lumer1020
    Participant

    Please tell me, did you get the logs?

    #44792
    Britgirl
    Participant

    Hi, yes we did thanks. We’ll be checking them soon.

    #44827
    kubaszym1
    Participant

    Hi,

    I found some errors in the logs that cause the failure of unmuting process. Although their cause is really hard to track. I noticed that they may occur when HDMI or ELD devices are used. Do you use a device that is plugged in with a HDMI cable?

    Also, the output of the command below would be helpful for further investigation:

    amixer -c 0 controls | grep “Playback Volume”

    Regards,

    Kuba

    #44843
    lumer1020
    Participant

    Hi!

    Thank you so much for your reply!

    Yes, indeed, when connecting to the server – there was an extra monitor connected. The role of the server was a laptop.

    What the command outputs (and a bit more) is attached with a screenshot.

    Attachments:
    #44876
    kubaszym1
    Participant

    Hi,

    It seems that it’s a kernel related issue. For some reasons ubuntu 22 with linux kernel >= 5.19.0-39 sometimes does not recognize or cannot mute/unmute HDMI devices. I’m trying to figure out a workaround for this, but maybe the only option is to downgrade to kernel like, i.e, linux-image-5.19.0-21-generic. Does the sound work outside NoMachine session if you set HDMI device as defualt? Can it be muted/unmuted outside NoMachine session?

    You can check your kernel version by running:

    uname -r

    Regards,

    Kuba

Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.