Ubuntu 24.04 showing squeezed screen on remote Windows-11 client

Forum / NoMachine for Linux / Ubuntu 24.04 showing squeezed screen on remote Windows-11 client

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #48074

    Hi Team,

    Great work.

    Just installed Ubuntu 24.04 on stand-alone HW, and installed the latest NoMachine version (nomachine_8.11.3_3_x64)

    From the Windows client, I see the Ubuntu 24.04 squeezed so I can not control it with a mouse please see the attached screenshot with the output of “xrandr” command.

    If I access my Ubuntu 20.04 no issue with the same configuration.

    Thanks for your support


    Hi, send us that screenshot to forum[at]nomachine[dot]com and I’ll attach it. Thanks


    When you say you “can’t control it”, what do you mean exactly? You can’t click on anything or something else? Have you tried the other view modes such as resizing the remote display? You can access the from the connection menu (Ctrl-Alt-0 or page peel)

    You can read more about these view modes here: https://kb.nomachine.com/DT09T00266#5.4

    If you’ve tried changing the view mode and that doesn’t help, please send us the logs from both the Windows and Ubuntu machines. You can extract them using the instructions here: https://kb.nomachine.com/DT07S00243.

    Send them to forum[at]nomachine[dot]com. Please use the title of this topic as the subject of your email. Thanks!


    Hi Britgirl,

    What I  meant, the mouse X-position on the client does not match the X-position on the server, and yes I tried all combinations on different client Windows machines and got the same results.

    Yesterday I rebooted the machine several times with no luck.

    Good news, last night I shutdown the machine, and this morning it looks ok, with no issues on the client side both screens match perfectly, I guess we need to do hard boot after installing “no-machine” on Ubuntu 24.04 Just reboot didn’t cut it.

    Thank you for your quick response, you can close this issue.

    Best regards,




    Ok thanks for letting us know. If happens again, submit the logs 🙂

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.