Ubuntu password not working

Forum / NoMachine for Linux / Ubuntu password not working

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #25537


    we logged in with ubuntu user until recently and it stopped working (not accepting password).

    Reinstalling NoMachine didn’t solve it.  I can get to the server but it keeps rejecting the password.

    Latest version of NoMachine on ubuntu 18



    There are a few things to check:

    1. In /usr/NX/etc/server.cfg what are the values of keys EnableUserDB and EnablePasswordDB?
    Are they commented?

    If they are commented or set to 0 it means the NoMachine will use
    system authorization to authenticate users. Skip point 2 and go to the point 3.

    2. If both this keys are set to 1, NoMachine is using the internal password database
    to authenticate users. please use command

    # /etc/NX/nxserver --passwd <username>

    to set new password and try again.

    3. To rule out the simplest mistake, please check if you can use the username/password to login into system.

    4. To check for NoMachine authorization problems please run

    /usr/NX/bin/nxexec --auth

    and use the Username and password used for failed connection. Please provide us
    with output.

    5. Please check the NoMachine log files for errors/warnings connected with the user login
    Files are /usr/NX/var/log/nxserver.log and /usr/NX/var/log/nxerror.log.

    6. Please check the system log file – for ubuntu it should be /var/log/auth.log – for any errors connected with failed login.



    solved by Adding :

    AvailableSessionTypes unix-remote,unix-console,unix-default,unix-application,shadow,unix-xsession-default,unix-gnome,unix-xdm,windows,physical-desktop


    to my server.cfg

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.