Unable to Authenticate for Software Update

Forum / General Discussions / Unable to Authenticate for Software Update

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #8189


    I am trying to run Software Update under Gnome on Red Hat Ent Linux version 6.7 (running as a virtual guest under VMware) from a normal user account over NX v4, but after checking dependencies and downloading the software, Software Update never opens a window to prompt for root authentication to complete processing the transaction.  There is a message on the lower edge of the Software Update window saying “Waiting for Authorization”.  I am running NoMachine Workstation Subscription v 4.6.12.  There are no errors in var/log/messages or any other log files that I check for that matter.  I am able to run other RHEL Gnome desktop system-config tools and they work just fine, prompting for root authentication and then performing the action properly.  It just seems to be with Software Update.

    [In an unrelated incident, I vaguely recall a few years ago having similar issues running Software Update over NX under Fedora (maybe 17?) and having to change a security setting in a config file located somewhere in /etc to run Software Update, and then after running update, changing the setting back to prevent regular users from being able to run update. But my memory of that event is fuzzy and it may have nothing to do with my current problem.]





    Turns out this is a polkit issue, although I’m not sure if it is strictly a polkit issue (very likely) or some kind of polkit/NX Connect interaction issue (much less likely).  I temporarily edited the /usr/share/polkit-1/actions/org.freedesktop.packagekit.policy file (permanent edits to this file is not the recommended approach to solving such problems!) and set the <allow_any>,<allow_active>, and <allow_inactive> settings to “yes” for actions <action id=”org.freedesktop.packagekit.package-install”> and <action id=”org.freedesktop.packagekit.system-update”>.  This permitted PackageKit to run the system updates (although it hung at the last clean-up step, probably because I hadn’t changed the <package-remove> action). I tried adding an override rule .pkla file to the /etc/polkit-1/localauthority directory, but that didn’t work for some reason or another.

    So it doesn’t look like a NoMachine issue.  I might recommend, however, that upon completion of the install, the nx-connect server package echo a note to the console suggesting the user check the statis of their polkit  files for administrative.  This would give them a hint where to start looking when things don’t work as expected.  Thanks!



    Thanks for taking the time to report your findings. We’ll be taking a closer look to see what’s going on.


    To deal with Software Updates problem inside NX sessions, we prepared article describing Polkit configuration.


    • This reply was modified 8 years, 8 months ago by frog.
    • This reply was modified 8 years, 8 months ago by frog.
Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.