Unable to change desktop environment in Mint 18

Forum / NoMachine for Linux / Unable to change desktop environment in Mint 18

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #12412

    I’m running Linux Mint 18 xfce on a intel NUC as a server in a headless setup. I’m connecting to it through a MAC and it’s working for the most part just great. However, it always connects using Gnome when I’d like it to be using xfce4.

    I’ve been searching around for several hours, and everyone says I need to change the

    DefaultDesktopCommand variable to:

    DefaultDesktopCommand “/usr/bin/startxfce4”

    I’ve also tried:

    DefaultDesktopCommand “/usr/bin/xfce4-session”

    Neither of these seem to work however. Is there something I’m missing? Do I need to change something else?

    Any help would be greatly appreciated!


    Hello Xaint,
    I was able to reproduce similar problems when I installed ‘xfce4-session’ using apt.

    However after I installed meta-package xfce4 and both commands which you used work correctly out-of-box. I tried /etc/X11/Xsession xfce4-session and it works also.



    Hi Brotech!

    Thanks for your reply.  I have the xfce4 mint meta package installed, but I saw a standalone xfce4 meta that I think you were referring to, and I have installed it.  I don’t know if there could be a conflict with having both.  Unfortunately, neither the ways I was trying or the Xsession way worked with the new package installed.  It still dumps me right into Gnome.

    I looked in the error log and it said it was looking for Node.cfg and not node.cfg on several lines.  I made a copy of it, and changed the owner to nx like the other one with the N capitalized.  It got rid of the errors, but I’m still getting Gnome.

    Is there another location where it looks for this?  Could it be the NoMachine client on my Mac computer?



    for sure NoMachine is using /usr/NX/etc/node.cfg as a configuration file where DefaultDesktopCommand could be set.

    Could you give a little more information about your configuration?
    Are you using the NoMachine free product ? Verify by running a command /etc/NX/nxserver –version. E.g.,

    /etc/NX/nxserver –version
    NoMachine – Version 5.1.44

    Is MDM working and do you get the login window ? If yes then you need to focus on MDM setup and select desktop kind using MDM’s menu (press letter M in top-right corner of login box) because xfce4 is started by MDM and NoMachine allows access to the physical DISPLAY whatever is running on it. So, there is no DefaultDesktopCommand in use.

    Any problem or errors related to session run should be in /home/USERNAME/.xsession-errors file.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.