Unable to connect after some amount of time on Debian

Forum / NoMachine for Linux / Unable to connect after some amount of time on Debian

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #48480
    DoctorDan
    Participant

    This was a post about Fedora from 2020.

    The suggestion about physicaldesktop had no effect in Debian 12.

    This is what happens. After poking around in the server when I am physically at the machine, NoMachine will allow me to log in from clients. Then, overnight, there is of course no NM client activity. When I return the next morning and try to access the server from a client it basically rejects my attempt and just returns me to the NM login screen. This has happened 5 days in a row now. It renders the whole NoMachine essentially useless.

    The server is Debian 12 up to date as of today. The client is Debian 12 up to date as of today The desktop on both the server and the client is xfce4. I have no idea whether I’m connecting to a physical or a virtual display since I don’t know what that means.

    On Windows 11 the client has no trouble connecting so the problem is likely to be something with the Linux client app.

    Hopefully there is a fix for this. If so, it would be extremely helpful if someone could tell me what it is.

    My attempts to use other VNC-type apps had been totally unsuccessful over the years on both Debian and Fedora before that so it seems as if there is only one option and that isn’t working.

    Please help!

    Thank you

    #48491
    Britgirl
    Keymaster

    Hi, which previous topic are you referring to? One you opened in 2020 is about macOS.

    You say that from Windows you can connect to the Debian server without problems. We assume you are connecting to the same Debian server as when you connect from the Debian client. Right?

    Can you submit a screenshot/screenshots of what you see when you try to connect from the Debian client? Are any error dialogs shown?

    Logs from the two Debian machines would be useful. Please follow the instructions here to enable debug and then gather the logs.
    https://kb.nomachine.com/DT07S00243. Send them directly to forum[at]nomachine[dot]com. Thanks.

    #48520
    DoctorDan
    Participant

    I didn’t generate the 2020 topic. I found it and it described the same problem that I am having on linux. So, I simply referred to it to make it clear that this issue has been around for a long time and has apparently never been addressed adequately.

    I can’t get a screenshot today because it’s working. When it doesn’t work, I enter the username and password and click connect and it just comes back to the username/password prompt again. Over and over.

    #48563
    Britgirl
    Keymaster

    When it happens again, please gather the logs from both sides.

    #48576
    DoctorDan
    Participant

    Linux debian-annex 6.1.0-21-amd64 #1 SMP PREEMPT_DYNAMIC Debian 6.1.90-1 (2024-05-03) x86_64 GNU/Linux

    xfce

    I don’t know if these are the right files

    Attachments:
    #48578
    DoctorDan
    Participant

    I also get this alot

    #48596
    Britgirl
    Keymaster

    The logs show that screen sharing is disabled. This suggests either that “Desktop Shared” is not enabled. You can check this in the NoMachine Server settings on the Debian host.

    Or that in Security -> Desktop Access, you have unticked “Don’t allow the owner of the desktop to connect if the desktop is not shared”. Are you always connecting from remote as the owner of the desktop? By “owner”, I mean the same user account that is actually logged on the Debian server.

    #48606
    DoctorDan
    Participant

    Are you always connecting from remote as the owner of the desktop?

    yes

    #48612
    Britgirl
    Keymaster

    Can you also check your permissions?

    home/essin/.Xauthority not writable, changes will be ignored
    368745 368745 2024-06-17 12:02:52 026.353 NXNODE   WARNING! Cannot remove cookie for :3002 from /home/essin/.Xauthority.
    368745 368745 2024-06-17 12:02:52 026.374 NXNODE   WARNING! Error is: 13, Permission denied.

    It is just a warning, but maybe this is blocking the connection.

    Check /home/essin/.Xauthority permissions and change the owner to essin (sudo chown essin:essin /home/essin/.Xauthority) or just remove the .Xauthority file (it will be re-created when you connect again).

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.