Unable to connect on Ubuntu

Forum / NoMachine for Linux / Unable to connect on Ubuntu

Tagged: , , ,

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #2764

    I am trying to connect to an Ubuntu ec2 instance on AWS. I am connecting via RDP (which is far from satisfactory, hence my interest in NoMachine) and have installed NoMachine 4. I have configured it according to the documentation using the RDP gui, but am completely unable to connect to it. Every time I try (from my laptop running Ubuntu), I get “Could not connect to the server. Error is 110: Connection timed out”.

    I have installed the web server trial and configured it, but am unable to connect.

    I’ve even tried installing it on my /other/ Ubuntu laptop and tried to connect from one to the other, with the same result. My laptops are running 13.04. The Amazon instance is running 12.04 (only because RDP isn’t properly supported on the newer versions–I was planning on getting NoMachine working, then upgrading). All NoMachine versions are up to date. I am using the standard Unity desktop on both physical machines and the virtual machine.

    If anyone can help, I’d much appreciate it.


    It seems that you cannot connect to your servers because of Firewall or NAT. If you are using NX protocol please ensure that the Security Group for your EC2 instance allows connections on port 4000.

    • This reply was modified 10 years, 2 months ago by reza.
Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.