Unable to connect remote disk

Forum / NoMachine for Mac / Unable to connect remote disk

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #19968

    I am working on a MacBook Pro (System Version:macOS 10.13.6 (17G65), Kernel Version: Darwin 17.7.0) and have installed NoMachine 6.3.6.

    When I try to connect a remote disk to my computer, there is an error message (Failed to connect the disk /storage. The directory /storage does not exist). Although I uninstalled and reinstalled the program multiple times, the dialog described here (https://www.nomachine.com/AR01P00962) does not show up, so it seems to me like I have to approve the KEXT in a different way.

    If you could advise me in any way, that would be highly appreciated!

    Many thanks


    Hello s.meliss,

    To make sure that this is the same issue as described in AR01P00962, please check the output of command  kextstat | grep nxfs after trying to mount a disk. If no output is shown, then you could try to load  the nxfs.kext file manually, with command sudo kextload /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/,  if it fails to load for the same reason as described
    in the article, you can proceed with following described steps(from AR01P00962).


    If nxfs.kext file fails to load even after following the steps, please share nx-related system logs with us(output of cat /var/log/system.log | grep nx).


    Dear ggham,

    Thank you for your response. I have copied the output below and hope that you can help.

    kextstat | grep nxfs--> no output shown

    sudo kextload /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/,

    /Library/Application Support/NoMachine/Extensions/nxfs.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).

    I have uninstalled and installed NoMachine several times, but never saw the dialog referred in AR01P00962.

    cat /var/log/system.log | grep nx).

    webvpn-65:~ stefaniemeliss$ cat /var/log/system.log | grep nx

    Oct 15 11:46:26 Stefanies-MacBook-Pro nxnode.bin[6334]: BUG in libdispatch client: dispatch_mig_server: mach_msg() failed (ipc/send) msg too small - 0x10000008

    Oct 15 11:57:38 Stefanies-MacBook-Pro nxnode.bin[301]: BUG in libdispatch client: dispatch_mig_server: mach_msg() failed (ipc/send) msg too small - 0x10000008

    Any further thoughts are highly appreciated.


    Dear s.meliss,

    This looks like a different problem to system policy preventing to load kext file.
    From the error displayed, it could be that NoMachine installation didn’t set up proper
    permissions to nxfs.kext file.

    Could you please check the output of ls -ld /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/
    it should be similar to drwxr-xr-x 3 root wheel. If the output is different, please try these two commands:
    sudo chmod -R 755 /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/
    sudo chown -R root:wheel /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/

    If this is not the case, and nxfs.kext still fails to load, please check if anything needs to be
    allowed in “System Preferences -> Security & Privacy -> General”(check AR01P00962) tab,
    just to be sure it’s not the issue described in the article, also, please try to load nxfs.kext using
    kextutil, since it will give more information in case of failure:
    sudo kextutil -t /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/



    Dear ggham,

    Thank you again for your reply.

    The command ls -ld /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/ gives the output drwxr-xr-x 3 root wheel as you would expect.

    I have been checking the System Preferences tab constantly while installing and using NoMachine, but it does not ask to enable the extensions.

    When I run the sudo kextutil -t /Library/Application\ Support/NoMachine/Extensions/nxfs.kext/ command, this is the output: Kext rejected due to insecure location: { URL = “file:///Library/StagedExtensions/Library/Application%20Support/NoMachine/Extensions/nxfs.kext/”, ID = “com.nomachine.kext.nxfs” }

    Diagnostics for /Library/Application Support/NoMachine/Extensions/nxfs.kext:

    Is there a way to enable the extensions during the installation using terminal commands? I have reinstalled NoMachine several times, but the GUI is not showing the dialogue as described in AR01P00962.

    Do you have any further ideas? Again, thank you for your help thus far.


    Dear s.meliss,

    The way to enable the extension is triggered by trying to load it for the first time, it can be done by either installing NoMachine, or doing it manually and you’ve tried both.

    Since you weren’t prompted with a dialog by system in either case, it makes me think the issue is something different, but I haven’t yet been able to identify the problem. Have you tried installing/loading other third party kernel extensions? I’m wondering if they’ll output the same error as nxfs.kext file.


    Dear ggham,

    do you have any examples for other third party kernel? From the top of my head I am not aware of any installed software. Do you think creating a new login with admin rights and repeating the installation process with it could circumvent the issue?


    Dear s.meliss,

    For instance you can test installing FUSE(https://osxfuse.github.io/) package that should contain
    .kext files, and check if you encounter same problem with it.

    I’m not sure if new login with admin rights solves the issue, since I haven’t identified the problem,
    but as a workaround you could try to disable SIP(System Integrity Protection) temporarily and then
    re-enable again after installing NoMachine and checking if disk is forwarded. I found this guide
    that describes steps required to disable and then re-enable SIP:


    Dear ggham,

    If I install FUSE, a dialogue as described in AR01P00962 pops up, so it is possible for me to enable the kext extentions. I then again de- and re-installed NoMachine, but the dialogue does not show up there. Further, after I disables SIP during installation following the instructions provided, I am still not able to connect the remote disks.

    Do you have any further ideas?

    Many thanks





    Dear s.meliss,

    Probably you have some problems with permissions. First of all you should check permissions of /Library/Application\ Support/NoMachine/Extensions by:

    ls -l /Library/Application\ Support/NoMachine/

    the result should be as follows:

    drwxr-xr-x  9 root  admin    288 Oct 31 14:26 Extensions.

    If your result is different, then set permissions with:

    sudo chown root:admin /Library/Application\ Support/NoMachine/Extension
    sudo chmod 755 /Library/Application\ Support/NoMachine/Extension

    Then check permissions of /Library/StagedExtensions/Library/Application\ Support/NoMachine/Extensions.


    ls -laO /Library/StagedExtensions/Library/Application\ Support/NoMachine/

    your result should looks like this:
    drwxr-xr-x  4 root  wheel  restricted 128 Nov  5 17:26 Extensions

    Make sure that you have restricted flag set. If not, then set it. The same for nxfs.kext inside this directory.

    ls -laO /Library/StagedExtensions/Library/Application\ Support/NoMachine/Extensions

    drwxr-xr-x  3 root  wheel  restricted  96 Dec 21  2016 nxfs.kext

    Then try to test the feature.

    If this doesn’t solve the problem, you should check if it is possible to remove the directory /Library/StagedExtensions/Library/Application\ Support/NoMachine or just file /Library/StagedExtensions/Library/Application\ Support/NoMachine/nxfs.kext.


    sudo kextutil -t /Library/Application\ Support/NoMachine/Extensions/nxfs.kext

    should create the directory and the file automatically with proper permissions.

    One more thing, you should make sure that your SIP has been enabled. You can do this with command

    csrutil status

    Please send us installation/update logs.

    /Library/Application\ Support/NoMachine/var/log/nxinstall.log
    /Library/Application\ Support/NoMachine/var/log/nxupdate.log

    I hope that this helps to solve your problem.

Viewing 10 posts - 1 through 10 (of 10 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.