Unable to create new display after upgrade to Fedora 26

Forum / NoMachine for Linux / Unable to create new display after upgrade to Fedora 26

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
  • #16299

    I went through the commands to get the log files, but when I ran the command ‘sudo tar cvfz NoMachine-log.tar.gz /usr/NX/var/log’ it ran for nearly 30 min before I stopped it. Are there any other steps I should do before running that?


    Strange, check how big are files and directories there with command:
    “sudo du -ha /usr/NX/var/log/”

    if nxserver.log or nxerror.log is too big, then try get last lines with command:
    sudo tail -10000 <path_to_log_file> > newLogfile.log

    Most requested files in that case are nxserver.log (with enabled SessionLogLevel 7 in server.cfg), nxerror.log and directory /usr/NX/var/log/node/ with its subdirectories.


    /usr/NX/var/log/node/ is 2.5GB and nxserver.log is 1.3GB I will run the command you listed for the nxserver.log, but what should I do about the directory?


    Use ls -ltr /usr/NX/var/log/node/ to check which directories are newest one. Take few from the bottom of list and pack them.


    You can send logs to forum[at]nomachine[dot]com


    Hi, I think I have the same issue after an upgrade from Ubuntu 17.04 to 17.10. I am using the nvidia binary driver and therefore Xorg (not wayland). The greeter is GDM and Gnome the desktop environment.

    I am able to reproduce the following behavior:

    1. Boot workstation
    2. Wait 1-2 minutes for NX to be ready
    3. Connect from remote (Windows or Linux does not matter) using NX
    4. The screen on the workstation goes black and remote shows the GDM login screen
    5. Login through NX
    6. The screen on the remote (!) goes black and the workstation shows the Gnome desktop as if I have logged in locally
    7. On the workstation, do a single click with the mouse (no matter where)
    8. The workstation drops to the console (the Gnome session remains running)
    9. Remote looses the connection to the workstation, at this point its not possible to re-login
    10. On the workstation, use Ctrl+Alt+2 to switch back to the Gnome session
    11. Reconnect with remote to the workstation using NX
    12. Screen on workstation goes black and I can work through remote -> all is fine 🙂

    I have also sent you the debug log to the provided address.

    Thanks & regards




    It  seems to be related to the “Lock the physical screen when somebody connects”. If I disable that option, I can disconnect and reconnect after I got a black screen on remote and all is fine (without any interaction on the workstation). There still seems to be a bug that I get a black screen after the login.



    New ubuntu (17.10) moved by default to Wayland and in same time they moved from unity to gnome3, so there is a lot of changes and incoming NoMachine version 6.0 should worked there correctly, but until that time please change in /usr/NX/etc/node.cfg field:
    DefaultDesktopCommand “/etc/X11/XSession ‘gnome-session –session=ubuntu'”
    DefaultDesktopCommand “env XDG_CURRENT_DESKTOP=ubuntu:GNOME GNOME_SHELL_SESSION_MODE=ubuntu dbus-launch –exit-with-session gnome-session –session=ubuntu”
    it could help in your case.


    The logs, etc requested have been submitted. Thank you.


    it looks like 10000 lines could be too little for debug.

    But please:
    If You have screen lock enabled please disable it. (Settings -> Power -> black screen -> never)

    try “sudo grep ‘1101 NXSERVER’ /usr/NX/var/log/nxserver.log > nxserver1101.log”
    but if nxserver1101.log will be to big to send, then use that command:
    “sudo grep ‘1101 NXSERVER’ /usr/NX/var/log/nxserver.log | head -30000 > nxserver1101.log”

    simliar things make for pid 27010:
    try “sudo grep ‘27010’ /usr/NX/var/log/nxserver.log > nxserver27010.log”
    but if nxserver27010.log will be to big to send, remove it and then use those two commands:
    “sudo grep ‘27010’ /usr/NX/var/log/nxserver.log | head -10000 >> nxserver27010.log”
    “sudo grep ‘27010’ /usr/NX/var/log/nxserver.log | tail -10000 >> nxserver27010.log”

    next useful commands:
    “sudo mv /usr/NX/var/log/nxserver.log /usr/NX/var/log/nxserver.log.old”
    then restart
    “sudo /etc/NX/nxserver –restart”
    wait 30-60 seconds
    then try to connect
    and then “sudo cp -p /usr/NX/var/log/nxserver.log nxserver-restart.log”
    nxserver-restart.log should be enough small to send us also, if not then:
    sudo grep -a -i -e ‘nxframebuffer’ -e ‘checklocalsession’ /usr/NX/var/log/nxserver.log > nxserver-restart.log

    then send please nxserver1101.log, nxserver27010.log and nxserver-restart.log.

    As usual send to our email address forum[at]nomachine[dot]com


    Logs have been submitted


    I see a lot of errors related to access to home directory, can you check if home directory of user tnt has correct permissions?

    To do that use:
    “ls -l /home/”

    and then check directory .nx inside with command
    “ls -la /home/tnt/” (option “a” is requested here, because it is hidden directory)
    In both cases owner of directory should be tnt and should have full rights on them (rwx)


    It’s a miracle. On the initial login I still get the flickering and it looks like it is going to just freeze and not load again, but I can now access my machine. Thank you very much for your patience and helping me.


    No problem munsen70 🙂

Viewing 14 posts - 16 through 29 (of 29 total)

This topic was marked as closed, you can't post.