Unable to find computer on VPN

Forum / NoMachine for Mac / Unable to find computer on VPN


Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #28631

    Hi there,

    I tried to remote control one desktop computer with Windows system from my Mac laptop. It requires VPN. I am pretty sure the VPN is working since I could remote control it via [removed]. However, when I tried NoMachine, it cannot find the desktop I want to remote control. In fact, it couldn’t find any computer within the same network. The NoMachine App in the remote computer has been set advertised and my colleagues can access via NoMachine. The attachment is the error report.





    on your MacOS, when you connect with a VPN and turn on NoMachine, you won’t see computers with NoMachine installed, as you do on your local network, mDNS doesn’t work over VPN. Computers with NoMachine installed from a network connected via VPN have no way to send information that they are ready to connect. In this case, they will not automatically appear in the NoMachine list as ready for connection.

    In the attachment, the address you are trying to connect to is blurred, is it really a local address from the network you connect to via VPN?

    To connect you will need the local IP address of the computer you want to connect to.
    Try to connect via NoMachine to this IP address with the VPN enabled.



Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.