Unable to start nxserver on RHEL 6

Forum / NoMachine for Linux / Unable to start nxserver on RHEL 6

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #25392

    Hi all. I am installing the free version of NoMachine on a RHEL 6 machine. I installed the NoMachine 6.9.2 RPM without a problem, but I can’t figure out what I am configuring incorrectly. The system already has the “nx” UID and GID defined. I copied /usr/NX/scripts/init/nxserver to /etc/init.d, but starting the service fails:

    service nxserver restart

    [root@dlasist2 NX]# service nxserver restart

    Stopping NoMachine.

    Starting NoMachine.

    [root@dlasist2 NX]# 31753 31753 18:47:35 601 nxexecExecute: ERROR! Can’t retrieve user info.

    31753 31753 18:47:35 601 nxexecExecute: ERROR! Error is Success

    NX> 900 NXSERVER – Version 6.9.2 – LS

    followed by all the help text for nxserver. We have another RHEL 6 system that is running an older version of NoMachine without a problem, and I’ve tried to make sure the /etc/init.d/nxserver script and the /usr/NX/etc/server.cfg files are analogous.

    Looking at the error logs, I see things like:

    In nxerror.log:

    13674 13674 18:36:03 670.532 Process: ERROR! Cannot get information for user id ‘20000’.

    13674 13674 18:36:03 670.602 Process: ERROR! Error is 2, No such file or directory.

    13674 13674 18:36:03 670.612 HostGetUserInfoByUid: WARNING! Failed to get process user information.

    Unknown option: daemon

    In nxserver.log I see:

    2020-01-27 18:36:03 670.779 13674 NXSERVER WARNING! Cannot get user info for 20000.

    2020-01-27 18:36:03 670.901 13674 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.

    The UID/GID for nx is 225 on the working and non-working machines. But it looks like the error messages indicate the nxserver is trying to launch under UID 20000 – which is the port range base, right?

    Is there some other configuration change I need to make? The web page for installing and configuring the free version does not discuss any of this.

    Thanks in advance,

    Eric Winter, Space Telescope Science Institute



    I deleted everything, then reinstalled using “rpm” instead of “yum” – and everything worked fine immediately. <scratches head>…..

    I guess this item can be marked closed, or whatever else is appropriate, since a response is no longer needed.


    Ok, thanks for letting us know 😉

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.