Unable to view server status on Raspberry Pi 4

Forum / NoMachine for Raspberry Pi / Unable to view server status on Raspberry Pi 4

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
  • #30867

    I just installed nomachine_7.0.211_1_armhf.deb on a Raspberry Pi 4 running Buster with the latest upgrades.  I also installed NoMachine 7.0.211 on a MacBook Pro running MacOS Big Sur 11.1.

    When I log onto my Raspberry Pi from my Mac and click on the NoMachine icon in the taskbar, I see a menu pop up (just like before) with one of the menu items “Show server status”.  When I select this menu, nothing happens.

    When I go to the Raspberry icon in the upper left and select either Internet->NoMachine->NoMachine or Internet->Nomachine->Nomachine Service nothing happens.

    So…how can I determine the server status of NoMachine on my Raspberry Pi?  Before, I’d just use the Server Status menu from the NoMachine icon in the taskbar, but I can’t to this any more.  Something has changed between NoMachine versions 6 and 7.


    We cannot reproduce this problem. Is that Buster for armv7 (you can check your architecture with command uname -a)? Please open terminal and execute: /usr/NX/bin/nxplayer --dialog status and report what happened.


    Here is the result of uname -a:

    pi@w3yj-pi4-old:~ $ uname -a
    Linux w3yj-pi4-old.ddns.net 5.4.79-v7l+ #1373 SMP Mon Nov 23 13:27:40 GMT 2020 armv7l GNU/Linux

    This can’t be good, I get a core dump when checking the nxplayer status:

    pi@w3yj-pi4-old:~ $ /usr/NX/bin/nxplayer –dialog status
    Segmentation fault (core dumped)

    Would the core dump be of any value to you?  Unfortunately it is too large to upload to the forum.


    Hi hpb,

    We are still unable to reproduce the problem.

    Logs would indeed be useful, you can send them to forum[at]nomachine[dot]com, referencing the topic as subject.

    We need logs of player and server both from rpi machine, plus server.cfg and node.cfg. – to check if some option(s) were changed, which provokes the problem.



    I completely removed NoMachine:

    sudo dpkg –remove nomachine

    For good measure, I deleted the /usr/NX directory:

    pi@w3yj-pi4-old:/usr $ sudo rm -rf NX

    I then reinstalled NoMachine:

    i@w3yj-pi4-old:~ $ sudo dpkg -i nomachine_7.0.211_1_armhf.deb
    Selecting previously unselected package nomachine.
    (Reading database … 243819 files and directories currently installed.)
    Preparing to unpack nomachine_7.0.211_1_armhf.deb …
    Unpacking nomachine (7.0.211-1) …
    Setting up nomachine (7.0.211-1) …
    NX> 700 Starting install at: Thu Dec 24 14:26:55 2020.
    NX> 700 Installing: nxclient version: 7.0.211.
    NX> 700 Using installation profile: Debian.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Compiling the USB module.
    NX> 700 Installing: nxplayer version: 7.0.211.
    NX> 700 Using installation profile: Debian.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 To connect the remote printer to the local desktop,
    NX> 700 the user account must be a member of the CUPS System Group: lpadmin.
    NX> 700 Installing: nxnode version: 7.0.211.
    NX> 700 Using installation profile: Debian.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Creating configuration in: /usr/NX/etc/node.cfg.
    NX> 700 Installing: nxserver version: 7.0.211.
    NX> 700 Using installation profile: Debian.
    NX> 700 Install log is: /usr/NX/var/log/nxinstall.log.
    NX> 700 Creating configuration in: /usr/NX/etc/server.cfg.
    NX> 700 Install completed at: Thu Dec 24 14:27:44 2020.
    NX> 700 NoMachine was configured to run the following services:
    NX> 700 NX service on port: 4000

    Logged on with NoMachine, and I have the same problem, unable to click on the NoMachine icon in task bar and see Service Status window.

    Here are contents nxserver.log.  I have verified that htd.cfg does not exist.

    1620 1620 2020-12-24 14:27:47 757.148 NXSERVER WARNING! Cannot open: /usr/NX/etc/htd.cfg.
    1620 1620 2020-12-24 14:27:47 757.421 NXSERVER WARNING! Error is: 2, ‘No such file or directory’.
    1620 1620 2020-12-24 14:27:47 757.864 NXSERVER WARNING! Service ‘nxhtd’: Wrong format of PID read from file ‘/usr/NX/’: .
    1620 1620 2020-12-24 14:27:47 776.020 NXSERVER Starting RS 7.0.211 and services.
    1620 1620 2020-12-24 14:27:47 776.302 NXSERVER System information: Raspbian GNU/Linux 10 (buster), standalone.1953 1953 2020-12-24 14:28:29 495.269 NXSERVER User ‘pi’ logged in from ‘’ using authentication method NX-password.
    1953 1953 2020-12-24 14:29:49 139.814 NXSERVER User ‘pi’ from ‘’ logged out.
    2641 2641 2020-12-24 14:29:59 497.524 NXSERVER User ‘pi’ logged in from ‘’ using authentication method NX-password.

    I have attached node.cfg, server.cfg, and nxerror.log.  Please let me know if there’s anything else I need to provide.




    One last thing to think of…I am unable to view the NoMachine machine status while logging in with NoMachine.  This is a headless Raspberry Pi so it’s a pain for me to hook up an external monitor.  It is possible that the security of NoMachine is preventing me from viewing the status window remotely?  If so, this is a change from Version 6 on my other systems.


    Can you please send the logs directly to forum[at]nomachine[dot]com. They were possibly too big to be accepted here.


    You could contact us at forum[at]nomachine[dot]com if you want to get a binary fixing the issue. We’ve documented it here:



    Yes, I would like a binary to try.  Thank you so much!  This is great customer service.

    For what it’s worth, I could not find anything in various logs when this problem happens.


    Thank you for your feedback!

    Could you please send us an email directly to forum[at]nomachine[dot]com? So we can send the binary fixing to your email.  Please make sure you reference the title of this topic in your email.




    For what its worth, I have exactly the same problem. The server window or main window will not show either via VPN or on direct video display to the Pi.


    I’ve tried uninstalling, reinstalling many times, updating raapbian and some other settings but just get the segmentation error. Very rarely it works one after fresh reinstall but then stops again.



    Would you like to receive the patched binary for testing as well? 🙂


    I already received a link to a patched nxplayer.bin from Carin.  I will download and test later today.  Thank you!


    oops sorry @hpb,  my question was for @John_miffy 😉


    The binary emailed to me by Carin fixed the problem.  I am now able to view my system’s status.  Thank you!

Viewing 15 posts - 1 through 15 (of 18 total)

This topic was marked as solved, you can't post.