Unreliable drag and drop behaviour when connected to a Mac

Forum / NoMachine for Mac / Unreliable drag and drop behaviour when connected to a Mac

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #33368

    I use NoMachine to connect to an M1 MacBook Air from a Windows 10 system. When using the mouse to drag and drop screen elements or to select text, the on-screen distance actually dragged will usually be much less than the distance the server registers.

    For example, a dragged 100×200-pixel rectangle may, when releasing the mouse button, be 300×150 pixels in size, and the mouse pointer jumps to the corner of the larger rectangle. Those numbers aren’t actual measurements, but the extra distance does appear to be proportional, or roughly so, to the distance and direction the pointer is dragged. Another example: dragging to select the words “Unreliable drag and drop” from the title of this thread may result in the selection of “Unreliable drag and drop behaviour when con”.

    Sometimes this behaviour can be reset to working correctly by disconnecting and reconnecting the client to the Mac’s NoMachine server, but it’s typically only a few minutes before it returns.

    The problem has persisted after complete uninstalls and reinstalls of both NoMachine programs, and restarts of both machines.

    I use the client in full-screen mode with the server’s resolution scaled automatically to match. The Windows 10 system has a 27″ screen  with a native resolution of 2560×1440, while the MBA has a 13.3″ screen with a native resolution of 2560 × 1600.

    • NoMachine 7.41 on both machines.
    • M1 MacBook Air (remote machine) running macOS 11.3.1
    • Windows 10 (local machine) running Windows 10 version 1909 with Windows To Go.


    does this issue occur only when using fullscreen mode? And does it occur only when the remote screen is scaled (i.e. does it occur also in ‘viewport’ mode)?

    Then please try to add the following key in the /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfg file on the server machine:

    DisplayServerExtraOptions "-oldeventapi 1"

    Restart NoMachine and see if anything changes.


    Hi fra81,

    First let me make a slight correction to my OP: I use the software in Resize Remote Display mode in conjunction with Full Screen.

    Very brief testing shows the problem occurs in Full screen and Windowed modes, using either Scale to Window and Resize Remote Display. It does not occur in Viewport mode.

    I will add the key to the file you suggested and update this post or make a new one to let you know if it worked.


    Thank you fra81,

    Adding the above key to the node.cfg file and restarting NoMachine seems to have fixed this issue for me. I have only tested very briefly though, so I’ll report back if the issue recurs.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.