Updated Fedora 25 – virtual desktop problems

Forum / NoMachine for Linux / Updated Fedora 25 – virtual desktop problems

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #13890

    When rebooting my fully updated Fedora 25-server (running xfce4), it seems that maybe some Fedora package update the last few weeks have caused serious problems. Some critical applications (like xfce4-terminal and Firefox) fail to start completely when running a virtual desktop (execution stops with a Segmenation Fault, see attached picture). If I login on the physical screen, the applications works as expected. The problems happens no matter if I configure AgentLightWeightMode 1/0.



    It’s a known issue but isn’t dependent on NoMachine. There is link with bug report and workaround https://bugs.launchpad.net/ubuntu/+source/libepoxy/+bug/1574886.

    Add new symlink from your library video card drivers to libGLX_indirect.so.0. For example:

    ln -s /usr/lib64/libGLX_mesa.so.0 /usr/lib64/libGLX_indirect.so.0


    Thanks a lot for that information, the workaround suggested solved the issue! Seems to be solved upstream now as well…

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.