USB device is forwarded, but OS does not see it

Forum / NoMachine for Linux / USB device is forwarded, but OS does not see it

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #48494
    takbal
    Participant

    Running 8.11.3 Enterprise Client Windows 11 client to connect to Ubuntu 22.04 8.11.3 server.

    % uname -a
    
    Linux box 6.5.0-35-generic #35~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Tue May  7 09:00:52 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

    nxusb kernel module is compiled and works:

    # lsmod | grep nxusb
    
    nxusb                  45056  5

    I am trying to forward a USB device (a fingerprint reader) of the Windows client with the Linux server.The device is listed in the “local devices” list, and I am able to release and reconnect it. It is shown in the list with a green button, and it is in the list as “1 connected device”.

    Seems like as far as NoMachine concerned, the device is perfectly well shared with the server. The problem is that the machine itself seems to be not aware of this. Whatever I do, lsusb does not show the device. The weird is that this is a recent thing, as it was working for years before.Tried recompiling the module, restarting everything, reconnecting many times – still same result.

    `# cat nxserver.log | grep Usb

    47959 47959 2024-06-14 10:49:23 275.298 NXSERVER Module NXUsb already loaded.

    47959 47959 2024-06-14 10:49:23 275.634 NXSERVER NXOpen FD#10 – file /usr/NX/etc/usb.db with mode 0 and permissions 0 from NXUsb::__del.

    47959 47959 2024-06-14 10:49:23 275.745 NXSERVER NXOpen FD#12 – file /usr/NX/etc/usb.db.tmp.47959 with mode 1089 and permissions 384 from NXUsb::__del.

    47959 47959 2024-06-14 10:49:23 275.998 NXSERVER NXClose FD#12 from NXUsb::__del.

    47959 47959 2024-06-14 10:49:23 276.051 NXSERVER NXClose FD#10 from NXUsb::__del.

    47959 47959 2024-06-14 10:49:23 276.352 NXSERVER NXUsb: Deleted usb entry for: 757B7721CB7BE45EED42005C10517E3A.

    64756 64756 2024-06-14 10:50:10 864.347 NXSERVER Handling code 1052 with function handleUsbConnected.

    64756 64756 2024-06-14 10:50:10 864.573 NXSERVER NXOpen FD#8 – file /usr/NX/lib/perl/nxserver/NXUsb.pm with mode 0 and permissions 0 from main::nxrequire.

    64756 64756 2024-06-14 10:50:10 868.110 NXSERVER Loaded module: NXUsb.

    64756 64756 2024-06-14 10:50:10 869.557 NXSERVER NXOpen FD#10 – file /usr/NX/etc/usb.db with mode 1089 and permissions 384 from NXUsb::__add.

    64756 64756 2024-06-14 10:50:10 869.723 NXSERVER NXClose FD#10 from NXUsb::__add.

    64756 64756 2024-06-14 10:50:10 870.189 NXSERVER NXUsb: Added usb entry for: 0B62BB53A5F4ADCA64359AF2C6B9D258 with Hub-Port: 0-0.`

    #48591
    pfitas
    Participant

    Have you tried forwarding other USB devices? Do they also have this problem? Did you use other USB forwarding software or did you have it installed previously? (it can cause conflicts with NoMachine USB)

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.