USB devices and Raspberry Pi

Forum / NoMachine for Raspberry Pi / USB devices and Raspberry Pi

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #13118


    NoMachine is really quite stunning as a remote desktop solution.  Once I sorted out audio, which was a bit of a pain on the Raspberry Pi, it’s playing back 30fps fast-moving music videos from a Windows 10 remote on VMWare with perfect lipsync and scarcely a dropped frame.  Light years ahead of any other solution I’ve tried bar Windows’ own (which of course won’t run on a Pi!)

    I have one problem I can’t seem to solve, though: USB devices.  I know that the ARM version is in alpha, so it may just be that it’s not working yet…?

    If I connect a USB storage key to the Pi, Debian (Jessie) immediately spots it and offers to open it.  Whether I do or don’t let Debian open it, NoMachine won’t see the USB device, just says “no devices found”.

    Anything I can try to get that working?




    Found this…

    The kernel headers on RPi are called raspberrypi-kernel-headers, not the naming suggested.  The make has to be run in a root shell, or it fails trying to overwrite one of the modules as output.  Make clean doesn’t work fully – something about a dangling symlink.  Other than that, the compile seemed to work.

    With the compiled driver in place and a reboot done, NM now offers me the option to connect a local USB device (previously greyed out), but still does not see the attached USB storage key.

    Anyone got any further ideas?  Can I get NM to offer up any debugging as it tries to see the USB device?


    At the moment USB devices are not supported on RPI architecture, just printers and disks.
    We created a Feature Request which you can view here:
    Extending NoMachine USB support to Raspberry Pi

    As a workaround you can add your USB flash drive as a disk:
    1. Go to Menu
    2. Open Devices tab
    3. Open Connect a disk
    4. USB flash drive will be visible as a disk
    5. After connecting the USB flash drive appears on your desktop.

    Let us know how you get on 🙂


    Thanks.  Seems ok as a disk, yes…  In the real world, I’ll need to add a USB headset as well as to be able to plug in USB storage, so I guess that’ll have to wait for the feature request to find its way into a release.
    Thanks for raising that 🙂



    Incidentally – your link to the FR gives me a 404 type error page.


    Sorry about the link. I just fixed that.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.