User unable to connect to NoMachine after reboot

Forum / NoMachine for Windows / User unable to connect to NoMachine after reboot

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #41804

    After every reboot of computer I’m unable to connect to NoMachine server, I have to open the program, restart server and than it is OK to next reboot.

    I have Windows 11 (version 22H2) and running NoMachine version 8.2.3 (desktop shared)


    Hi, can you confirm that the check box “Start the server at system startup” is showing as enabled? Go to ‘Server setting’ on the affected computer, open NoMachine and proceed to Server settings -> Status -> just below “Restart the server” there is the checkbox.



    Any progress, yesterday in the morning was all OK, but later during the day I was unable to connect, the check box “Start the server at system startup” was/is enabled.


    We will need to see logs from the affected Windows server. First enable verbose 7 in the server settings (Settings -> Server -> Server status) on the Windows 11 machine and restart the nxserver. Reproduce the problem.

    Then find the \NoMachine\var folder which on Windows is generally at this path: C:\ProgramData\NoMachine\var\

    and create a zip file of it.

    Then find


    and zip up that folder as well.

    Send both to us using forum[at]nomachine[dot]com. Please use the topic’s title as the subject of your email. Thanks!



    The logs do not show the problem and the .nx folder is missing from users home.

    So let’s do it this way:

    Follow the instructions here:

    To enable debug on Windows, open a CMD console as administrator:

    > %ALLUSERSPROFILE%\NoMachine\nxserver\nxserver.exe --debug --enable all

    Reproduce the problem and then:

    > %ALLUSERSPROFILE%\NoMachine\nxserver\nxserver.exe --debug --collect

    Send as before. Thanks!


    I see this topic has come up a few times here. We have a very similar experience. In our case, NoMachine Enterprise Desktop with Windows 10.

    After restarting, although the service is enabled, it cannot be connected (must be restarted manually via RDP connection). Or after some time, in the order of minutes to about 3 days after the restart, the service will cease to be available. Or I’m connected and the desktop suddenly freezes. If I’m quick about opening a new connection, I continue on the new one (and the old one shows a frozen state until I close it). If I don’t connect in a while, the server freezes as well.

    Freezing desktops in all cases have a longer history, have undergone NMv7 upgrade to NMv8 (32 bit), uninstall and install NMv8 64-bit. Another thing is that it’s about loaded systems. For example, it is enough to disable the Windows search service or move the system to a more powerful/less loaded cluster node and the problems will stop (all these are virtualized libvirtd/KVM systems, RedHat cluster suite, CentOS7, Fujitsu Primergy servers in the background, multiple clusters). With NMv7 there were no such problems, even systems that are cleanly installed directly as NMv8 64-bit are OK.


    Majkl, we will need the same logs that we requested also from you from the affected Windows NoMachine server 🙂 Enable debug, reproduce the problem and zip up the logs. See my earlier reply for the commands.

    Please also confirm the following because it’s not clear from what you wrote:

    NM7 ED on Windows showed no issues
    NM8 ED on Windows 32bit – did this show the issue or not?
    NM8 ED on Windows 64bit – did this show the issue or not?


    NM7 ED: OK

    NM8 ED 32bit  and 64bit – they fall

    Now we have the last ED that hasn’t been reinstalled from scratch and I see that it’s just dead. 🙂

    See Annex. NM service panel reports that it is running. But according to netstat and tasklist, it can be seen that the nxd service is missing (and a few others, if I compare with a working node) and nothing is listening on the TCP/4000 port. If I switch to the ports panel: NX, SSH, HTTP start as running first, and after a few seconds it correctly shows that nothing is running (only NX is enabled).

    So reboot, turn on debug and wait for the crash… This ED is now free for experimentation. Otherwise, it is connected to a cloud server (direct, tunnel mode).


    Hi Majkl, thanks for the additional info. We’ll wait for the logs. Once you’ve got debug enabled, reproduce the problem(s) and then %ALLUSERSPROFILE%\NoMachine\nxserver\nxserver.exe --debug --collect 🙂 Submit everything to forum[at]nomachine[dot]com.



    Thanks for the logs. They were useful but why it’s happening is still not clear. We’re still trying to reproduce your issue.

    In the meantime, could you send us the contents of C:\Program Files\NoMachine\etc\nxdb? Just zip up and send like you did the logs. Thanks!


    Majkl, we got the nxdb file.

    Could you try running as admin:

    C:\Program Files\NoMachine\bin\nxserver --updatedb

    There is chance that it will fix some problems. Do it if possible when nomachine is shutdown.

    Also clean reinstall (removing old files) could solve issue.


    Just to add that, what we found in the nxdb file is that updating to v8 from v7 was not done cleanly. This will be fixed in the next maintenance release. Hence a workaround is to run the command suggested just above 🙂


    For the record, how I turned out:

    The command “nxserver –updatedb” did not help.

    After a complete uninstall, deleting everything from NX and a new installation of ED 8.3.1, it works OK.

    So I agree there was some issue with the NXv7 to NXv8 transition, we ended up with a clean reinstall of all EDs (and similarly had to clean reinstall the Enterprise Clients, due to disk sharing issues).

Viewing 13 posts - 1 through 13 (of 13 total)

This topic was marked as solved, you can't post.