Version 8.10.1 NM services will not start until after local login on remote machine

Forum / NoMachine for Linux / Version 8.10.1 NM services will not start until after local login on remote machine

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #46560
    dje666
    Participant

    Dear NM-F,

    I have NM installed and running on an Ubuntu 22.04.3 LTS host, accessed remotely via various Win10 and Apple devices. I have enabled the “Make access available when the system is still in the login screen” option, but this is not working with the NM server not starting until after I have logged into the Linux box locally.

    Once I have logged in locally, all my remote clients can connect as expected, but I must login on the server locally for the NM utility to start up.

    Any thoughts on how I can fix this issue?

    FYI, I have a second Linux box (laptop) configured in exactly the same way, and this machine does present a login screen over the NM services, so clearly the tools work, just not on my primary sever.

    Comparing the NM GUI server-settings of the two Linux machines has not yielded any obvious differences.

    Regards,

    DJE666

    #46587
    rairulyle
    Participant

    This also happens to mine after the v8.10.1 update too. I am using Ubuntu 22.04 LTS as the host.

    It can connect but it says that there are no available desktops on the server. I had to login so that the service would run and start to work again.

    #46591
    Britgirl
    Participant

    Hi to both of you

    we are aware of a similar issue. Logs from affected servers we have checked show the wrong behaviour is triggered someway by Wayland, our developers are looking for a possible solution, but in the meantime the suggested workaround is to disable Wayland.

    If disabling Wayland has no effect, please submit logs from the Ubuntu server side.  You can extract them using the instructions here: https://kb.nomachine.com/DT07S00243

    Send them to forum[at]nomachine[dot]com. Please use the title of this topic as the subject of your email. Thanks!

    #46592
    rairulyle
    Participant

    @Britgirl, I found a temporary. Other solution is to enable autologin for the preferred user so that it will launch the NoMachineService via user.

    #46598
    dje666
    Participant

    Dear Team,

    Yes, auto login for a nominated user is the solution I’m using for now.

    ta,

    DJE666

    #46614
    Britgirl
    Participant

    So, workarounds are either to disable Wayland or enable autologin.

    #46633
    Britgirl
    Participant

    Here is the Trouble Report link so that you can track the issue.
    https://kb.nomachine.com/TR01V11052

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.