Virtual Windows key mapped incorrectly on send

Forum / NoMachine for Windows / Virtual Windows key mapped incorrectly on send

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #47668

    I am using Dragon for keyboard interactions due to my disability issues. I would like to switch from chromium Remote Desktop to NoMachine solution but not being able to send a virtual Windows button is a hard blocker for me unfortunately. When I tried to send the Windows key in combination with other keys for copy and paste mainly, the Windows key does not come through correctly when sent as a virtual keypress. Is this something the team knows about and is working on? Thank you.


    Can you try enabling the keyboard grabbing. Go to Settings > Player > Input > Grab the keyboard input.

    More illustrated details are available here:

    What OS version are you connecting to?


    Thank you for the prompt response. I actually enabled the “Grab keyboard input” already.

    I am connecting to macOS 14 Sonoma from latest windows 11.

    I tried different ways of sending the Windows key from dragon and the Windows key Either simply doesn’t come through or it comes through as a tilde.

    I tried to outsmart my setup by using autohotkey to map the Dragon request to a macro from Auto hotkey to send the Windows key and/or the left Windows key and I actually saw the exact same result which led me to believe that a virtual Windows key press is problematic for the NoMachine setup.

    If this is expected to work, is there a way I can send you a debug trace or something?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.