White screen Nvidia driver

Forum / NoMachine for Linux / White screen Nvidia driver

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #44753

    I’m running Fedora Desktop 38 on client and server. with NoMachine-8.6.1-3.x86_64

    The client has Nvidia drivers installed. When I connect to the server I just see a white screen. Previously I have had no issues when I was running with video from the on CPU graphics.

    I’ve attached the log files.  Also, below is a screen shot. Any help would be appreciated.


    I should say I’m using Gnome 44 on both client and server with NoMachine Desktop Free version



    Thank you for your post.

    Logs from the $HOME/.nx directory on the server are missing (you sent only from the client). It would be nice to have them.

    Send logs file to forum[at]nomachine[dot]com.

    You can use the automatic procedure if you prefer (https://kb.nomachine.com/DT11R00182#1)




    I followed that process and attached the resulting zip


    Can you update to the latest version 8.7 and tell us if you have the same issue? A similar issue was reported on Debian and a fix was released in the maintenance update of today: https://kb.nomachine.com/TR07U10920


    I am having the same issue.

    Trying to connect to a Windows Desktop from Fedora 38 with the latest supported Nvidia Drivers from the repo—just a white screen.

    I also have Rocky Linux 9.2 installed on this computer, and from that one, it connects flawlessly, no white screen at all.

    I am using the latest available NoMachine 8.8.1 on both ends.


    Can you try disabling hardware decoding on the Fedora side, please?

    First exit the Player on the machine you are connecting from by right clicking on the !M icon in the sytem tray and clicking Exit Player.

    Edit %USERPROFILE%\.nx\config\player.cfg and set:

    <option key=”Enable hardware accelerated decoding” value=”false” />

    Then create a new session and check if you still have the white screen.

    If you do, set that key to:

    <option key=”Enable hardware accelerated decoding” value=”disabled” />

    and create a new session.

    The first setting disables the use of HW decoding but the codec library is still loaded, while the second settings
    disables completely the HW decoding and cannot be set via UI.

    Let us know the result. If it works,  it would be useful to know some hardware details so we can investigate internally. Which is the client side computer model, the graphics adapter name and the driver version?



    Ok, I have tried the steps you described. It still gave me a white screen using “false”, but with “disabled” it did work!

    However, I noticed the screen appears offset, which seems like a UI problem. See attached screenshot.

    This is the client machine specs:

    OS: Fedora Linux 38 (Workstation Edition) x86_64
    Host: X570 AORUS MASTER -CF
    Kernel: 6.4.6-200.fc38.x86_64
    Packages: 2956 (rpm), 41 (flatpak)
    Shell: bash 5.2.15
    Resolution: 1080×1920, 3840×2160, 1080×1920
    DE: GNOME 44.3
    WM: Mutter
    WM Theme: Adwaita
    Theme: Adwaita [GTK2/3]
    Icons: Adwaita [GTK2/3]
    CPU: AMD Ryzen 9 3950X (32) @ 3.500GHz
    GPU: NVIDIA GeForce GTX 1080
    Memory: 2890MiB / 64226MiB


    Sorry for not responding earlier. Do you mean that the image of the desktop is outside of the window frame?! Indeed very very strange. Can you check whether it happens in different view modes (viewport, scaling, resize etc). Does anything happen if you resize the window or move it around the desktop?

    We just released 8.9, does it still happen?

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as closed, you can't post.