White screen on connecting to Mac over VPN

Forum / NoMachine for Mac / White screen on connecting to Mac over VPN

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26828
    jjfranzen
    Participant

    I’ve been looking for a decent non Apple remote desktop solution for a mac for a while. I was hoping this might work. It seems fine when connecting between two systems at my home. But when trying to connect to a system at work over a VPN, all I get is a white screen. Looking at the display settings, I see something weird at the bottom. It’s reporting a screen res that seems almost random and a codec of Unknown. Very weird. I’ve attached a screen grab. And when I dig further, in the session log I see:

    NXAGENT – Version 6.9.2

     

    Copyright (C) 2001, 2019 NoMachine.

    See http://www.nomachine.com/ for more information.

     

    Session: Starting session at Thu Apr 16 16:34:25 2020.

    Info: Agent running with pid 9765.

    Info: Slave server running with pid 19715.

    Info: Display running with pid 19459.

    Info: Listening to slave connections on port 12001.

    Info: Event poller running with pid 14595.

    Info: Session is active.

    Info: Audio server started with pid 23811.

    Info: Audio client started with pid 24579.

    Info: Display server started with pid 40963.

    Session: Session started at Thu Apr 16 16:34:25 2020.

    nxagentSharedMemoryInit: WARNING! Failed to allocate shared memory segment of 67108864 bytes.

    nxagentSharedMemoryInit: WARNING! Trying to allocate 16777216 bytes.

    nxagentSharedMemoryInit: ERROR! Failed to allocate shared memory segment of 16777216 bytes.

    nxagentDisplayServerInit: ERROR! Failed to initialize the shared memory.

    Info: RT handler running with pid 86307.

    Info: Display server for B086A414C7BBB6216697A57CBC736A40 connected on Thu Apr 16 16:34:42 2020.

    Info: Audio server for B086A414C7BBB6216697A57CBC736A40 connected on Thu Apr 16 16:34:42 2020.

    Info: Audio client for B086A414C7BBB6216697A57CBC736A40 connected on Thu Apr 16 16:34:42 2020.

    Info: Audio reader running with pid 89607.

    9765 19459 16:35:40 631.338 DisplayServerApplication/MediaServerApplication: WARNING! Invalid encoder in method ‘removeEncoder’.

     

    That’s a lot of memory allocation errors there. Which implies a bad install, config, or something.

    When I try with two system on the same subnet at home, all is fine going in either direction. When I try from my work system to either home system over the VPN, it works fine. But when trying to connect from either home system to the work system via VPN, no joy. Just a white screen. Interesting to note, both home system report the same resolution and codec Unknown when trying to connect to the work system. This further implies to me an issue with the work system’s config or general software.

    I’ve already tried all the various codec settings in the server.cfg as well as disabling hardware acceleration to no effect. I even tried forcing a specific resolution with no joy. I’m kinda stumped here and the Googles aren’t helping.

    Any suggestions?

    Cheers.

     

    All systems specifics:

    My home systems are an Alienware Aurora running Windows 10 with all updates applied & a 13″ retina MacBookPro running OS X 10.15.4

    The work system is a 2013 MacPro running OS X 10.14.6.

    All are running the same version of NoMachine, 6.9.2

    #26850
    fra81
    Moderator

    Hi,

    those errors mean that it is not possible to allocate shared memory on your system, probably because it is exhausted. To confirm, please run the following commands in a terminal on the Mac at work and send us the output (you can attach here or send to forum[at]nomachine[dot]com):

    sudo sysctl -a | grep shm

    sudo ipcs -ma

    Quickest way to get rid of leftover shared memory segments is to restart the machine.

    #27252
    russellaugust
    Participant

    Was this resolved?  I am having this exact same error.

    I’m connecting to a iMac Pro (new iMac Pro with 3 monitors) over VPN. Sometimes it knows there are three monitors, other times it is blank with a random resolution and unknown codec.

    What’s strange is I can connect the other way:
    iMac Pro (remote) -> MacBook Pro (Home)

    But I cannot connect:
    MacBook Pro (Home) ->  iMac Pro (remote)
    Windows 10 (Home) -> iMac Pro (remote)

     

    #28556
    Britgirl
    Participant

    @russellaugust, if you are able to reproduce this issue using the latest 6.11 version, you should provide the output that fra81 requested in his reply. Otherwise, full logs from both sides of client and server would be useful.

    https://www.nomachine.com/DT10O00163

    #28647
    russellaugust
    Participant

    Hi Britgirl

    I started using NoMachine again on the 17th when you posted this.  I wanted a few days with it to get an idea of what was and wasn’t working.

    At first, I was still getting the white screen (Windows 10 User connecting to a MacOS Host).  I played with a couple settings on login and found that if I disabled the client side hardware decoding, It would work!

    I will log in and I can see the white screen behind the NoMachine Overlay when you first log in.  I go into Display Settings and when I disable client side hardware decoding and then I can see screen appear behind the overlay.  BUT if I re-enabled hardware decoding, I can still see the screen.  It doesn’t go back to white.  I’m not sure if the hardware decoding actually is really being enabled again though.

    Latency is a bit higher than it has been in the past (maybe like 250-500ms).

    Hope that info helps!

    #28671
    fra81
    Moderator

    Hi russelaugust,

    if you are using the latest NoMachine version (6.11.2) on the client, you could be reproducing this known issue:

    https://www.nomachine.com/TR06R09772

    #28742
    russellaugust
    Participant

    this appears to fix it!

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.