White screen when logging into Catalina client prior to client login

Forum / NoMachine for Mac / White screen when logging into Catalina client prior to client login

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #29137


    I’m testing my shared computer lab and am running into the following issue. I’m getting a white screen when trying to log into a macOS 10.15.6bCatalina client that is at the login screen. If the client is already logged in it logs in fine.

    I also often get the error: <No available sessions on this server>

    I’ve reviewed some of the other Catalina-related threads, and tried some of the suggestions, but still no luck.


    This is a known issue and there is a temporary workaround.

    White screen occurs when macOS is rebooted just after the installation of NoMachine

    If you want, I can send you a patched version for you to try.


    If you want, I can send you a patched version for you to try.

    Thanks Britgirl. Yes, I would be happy to try the patched version.


    The patched version gave me a black screen now instead of white.

    I also tried running: sudo /etc/NX/nxserver --restart 

    …which still resulted in a white screen or the error: No available sessions on the server

    Next steps?



    First two questions:

    1. Have you installed the new version from the desktop, or using command line? If from the desktop, has the user the administrator privileges?

    2. After installation were you prompted with accessibility questions?

    I am afraid this is something new that was introduced with the Catalina 10.15.6 update and has nothing to do with the accessibility any more, but we still need some data to
    handle this.

    Could you please follow this:

    Please do:

    sudo /etc/NX/nxserver --shutdown

    Then navigate the OSX options to the “Security and Privacy”, the “Privacy” tab and from both “Accessibility” and “Screen recording” options please remove (by clicking ‘-‘ button, not just by disabling the checkbox) any and all “NoMachine”, “nxnode” or “nxserver” entries.

    At this point for further investigation would be great to enable the logs in both server.cfg and node.cfg on the server machine. Please follow the article on how to enable debug:

    https://www.nomachine.com/DT10O00163 (“How to gather debug logs for support requests”)

    Then please do:

    sudo /etc/NX/nxserver --startup

    and accept any requests for permissions from the operating system.

    If the issue should persist after this, it would at least rule out any older bug being not fixed.
    In this case please gather the logs either manually or by executing:

    sudo /etc/NX/nxserver –debug –collect

    Please send the logs to forum[at]nomachine[dot]com using the title of this forum’s thread as the mail’s subject.



    We didn’t receive any further information from you so I have closed this topic. I advise you to update to the latest version and open a new topic if you encounter the issue again.

Viewing 6 posts - 1 through 6 (of 6 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.