Why Are There Two Physical Displays Shown When Connecting?

Forum / NoMachine for Mac / Why Are There Two Physical Displays Shown When Connecting?

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #6940

    When I am using NoMachine to connect to my Mac Mini (running Yosemite) from a Google Nexus 7 Android tablet, on the NoMachine Recent Connections screen on my tablet, I see an icon representing my Mac computer, this icon being labelled Mac, joe, SE, Mac OS X NX.

    When I double click on this icon, it takes me to a second screen entitled Mac which shows two further icons, both labelled Physical Display, User Joe, Mac OS X desktop on:1001.

    If I double click on one of these Physical Display icons, it then takes me to my live Mac computer desktop, and everything is hunky dory.

    However, if I click on the other identical Physical Display icon, nothing happens, and the NoMachine App just gets stuck for a long time doing nothing.

    In any case, there is this two-step process of getting connected to my live Mac desktop, going through the Recent Connections screen, and then going through the Mac screen.

    What is strange is that when I first set up this connection to my Mac, the second screen entitled Mac (and its Physical Display icons) never appeared at all. Initially, double clicking on the icon Mac, joe, SE, Mac OS X NX on the Recent Connections screen would take me straight to my live Mac computer desktop.

    However, after using NoMachine for a few days, this second Mac screen suddenly appeared in the connection process, and I would have to double click on the Physical Display icon on that second screen before I could get connected to my live Mac desktop.

    Also, when this second Mac screen initially appeared, it only had one Physical Display icon showing on it, which I had to double click. But after a few more days, a second Physical Display icon suddenly appeared on that Mac screen.

    I have tried completely uninstalling NoMachine on both my Mac and Android tablet, and this did initially reset everything, such that I could connect to my live Mac desktop in one step from the Recent Connections screen. But then again, after a few days, this second Mac screen suddenly came back, and I was forced to go through the two step connection process once again.

    My Mac Mini computer only has one screen connected to it (although some time ago I did have two screens running on it, as a dual monitor set-up).

    Does anyone have any idea of why this is happening?

    It did occur to me that NoMachine might think that there are still two physical monitors connected to my Mac, even though my Mac now only has one monitor.

    Is there any way to prevent this second Mac screen and Physical Display icons from appearing?

    Many thanks in advance for any advice on this.


    Hello G,

    We need debug NoMachine server logs to investigate further. Please follow the instructions here: https://www.nomachine.com/AR07K00677

    and send them to forum[at]nomachine[dot]com.

    After enabling debug logs on problematic machine please execute: /etc/NX/nxserver --restart

    and after that try to reproduce the issue.

    Please send first set of logs just after ‘restart’ and next part when the issues occurs again.

    Please also provide the exact version of OS X Yosemite that you are using.

    • This reply was modified 9 years, 2 months ago by Bilbotine.

    Hi Bilbotine,
    Many thanks for your post.
    I followed the instructions you provided above, and have emailed you the server logs.


    Hello G,
    Thank you for submitting logs.
    We need to ask for more information to investigate further.

    In logs you provided we are missing debug level logs from nxserver, please make sure that you set SessionLogLevel key on debug level in file /Applications/NoMachine.app/Contents/Frameworks/etc/server.cfg: ‘SessionLogLevel 7’

    The client side logs will be useful, please fallow the article: https://www.nomachine.com/AR04M00843 to gather them.


    By the way, when I followed your above instructions and then executed the Terminal command /etc/NX/nxserver –restart, this had the effect of reducing the number of Physical Display icons shown on my Android tablet from two down to one.

    (Incidentally I had to prefix that command with the sudo command, in order to provide administrator access necessary to get it to work).


    Hello G,
    We cannot reproduce the issue in our laboratory,
    please try to reproduce the issues with debug logs in nxserver enabled.


    Hi haven

    Thanks very much for your help with this issue.

    At the moment I am have trouble reproducing this problem myself. Having used the command /etc/NX/nxserver –restart a few times, this seemed to clear out the problem, and so far it has not returned. That is to say, the second screen containing these Physical Display icons no longer appears.

    However, the problem was intermittent anyway, so it may return in the next few days. When it does, I will send you the server side and client side logs as requested (sorry that I made a mistake earlier of not properly setting the SessionLogLevel to 7; I will make sure I get it right next time).

    One thing that occurred to me as the possible source of this problem is the fact that I have a second router running in my home, in order to provide good WiFi coverage across the house. Although both my routers are connected together, via an ethernet cable that runs from a LAN port on the first router to the yellow Internet port on the second router, these routers are not using the same LAN IP address range (the first Netgear DG834GT ADSL model/router has the LAN IP, and for attached devices issues LAN IPs in the range to 255; the second Netgear WNDR3400 router has the LAN IP, and for attached devices issues LAN IPs in the range to 255; I have not yet figured out how to get both routers to use the same LAN IP range).

    Depending on where I am in the house, sometimes my Android tablet will connect to the WiFi of the first router, and sometimes to the WiFi of the second router. Possibly this might be the source of the problem.

    Anyway, as soon as the problem occurs again, I will send you the logs.



    The other thing that might be the possible source of this problem is the fact that a while ago I had two displays connected to my Mac Mini, one through the HDMI port, and the other through the Thunderbolt port. But at the moment I just run my Mac with one display, connected via the HDMI port.

    However, I wonder whether my Mac may have maintained a some kind of configuration file somewhere for these two displays that I used, and it is this configuration file that is confusing NoMachine. If this were the case, then in order to replicate the problem, it might be an idea to connect two displays to your test Mac temporarily, and then revert back to using one display.

    The fact that when this problem occurs, NoMachine shows me the option of connecting to two different physical displays, but only one of these physical displays works to create a connection, suggests to me that NoMachine may still think that my Mac has two displays connected to it, and so is presenting the option of connecting to either display.

    I managed to reproduce the problem again, and have emailed you the client logs and the server logs.


    Hello G,
    Thank you for the provided logs. We have identified the issue and have opened a Trouble Report:
    You can use the ‘alert me’ check box to know when we have a fix.


    Thank you, Haven, I look forward to when the fix becomes available in a new version of NoMachine.

Viewing 10 posts - 1 through 10 (of 10 total)

This topic was marked as solved, you can't post.