Win-Win NoMachine unable to connect anymore

Forum / NoMachine for Windows / Win-Win NoMachine unable to connect anymore

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #24123

    Hello Everyone,

    I’ve been trying to figure out a good way to connect to a remote Windows 10 machine (from my Win10). I’ve been using [remote access product], but I don’t really like that. I tried out NoMachine, and it seemed to work pretty nicely. A few quirks, but they were at least mostly my fault for not learning more about it.

    But then for no reason I could determine, I started only getting timeout errors.

    First thing I did was make sure that the IP of the ‘server’ was still the same which it was. I checked that multiple times, with Windows and with the browser. I checked the Windows-firewall rules for NoMachine, they were still in place and activated on both machines. I have tried completely deactivating the Windows firewall on the “server” side, just to see if that helps at all. It didn’t…

    I’m out of ideas…. If someone has an idea what I could do I’d be really greatful. If you could include an explanation on why it’s not working or what I did wrong, that’d be very much appreciated, because I’d like learning more about NoMachine.


    Thank you, everyone,



    (I’m trying to connect from a win10 1903 to another win10 1903 I’m using version 6.8.1, downloaded on the 02.10.2019. Both machines are physical, and connected over the internet (computer-router-internet-router-computer))


    Is it happening before or after login?

    To understand better what is happening, we need to see the server-side logs from the destination Windows host.
    Please follow the instructions here: and then send them to forum[at]nomachine[dot]com.
    Enable logs, restart NoMachine, reproduce problem, gather logs and send them.
    Also output from nxserver –status could be useful.



    Thank you for the answer.

    I can’t reproduce the mistake at the moment, but get another one. A quick google search tells me that there’s already people having had that problem, so probably there’s a solution to it. I’ll look into it, when I got more time this weekend.

    If I can reproduce the mistake I will and come back.

    I’m sorry for this….


    I just looked into the logs, it looks as if there were a few rather personal information in there…

    Is there a way to clean them up?


    Thank you for your time!



    You’ll have to delete out the personal information when you are ready to submit them.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.