Windows 10: No USB devices detected for forwarding

Forum / NoMachine for Windows / Windows 10: No USB devices detected for forwarding

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #30313

    I’m using NoMachine 6.12.3 to connect from Windows 10 (physical) to CentOS 8.2 (virtual/Wayland) but, on the Windows 10 side, the client does not enumerate any USB devices. Is this a known issue?

    In device manager, I have 3 NoMachine USB Host Adapters
    In services, the NoMachine Device Server is running

    I’ve attached some screenshots and the log files, hopefully it helps point to the issue.








    Windows side logs look good, and the USB forwarding module works well on that side.

    Most probably you have some issue with the remote, Linux side. Please check this article:

    As well as please attach logs from the Linux side if possible.


    You’re right, the USB module has not been built on the Linux side. However, I can’t seem to compile them.

    As soon as I execute make, it stops with `error: macro “access_ok” passed 3 arguments, but takes just 2
    if(!access_ok(VERIFY_READ, (void *)iso, iso_count * sizeof(struct eveusb_vhci_ioc_iso_packet_giveback)))`

    The target machine is CentOS Linux 8.2.2004 (core) and I’ve installed kernel-devel-4.18.0-193.28.1.el8_2.x86_64.rpm


    It seems that the issue is caused by the newest Linux Kernel update for RHEL OSes.

    Please replace the file with the one you receive (via mail to the address you used to register ) in the /usr/NX/share/src/nxusb/ directory and try to build it again.

    I hope it’ll help.

    The Trouble Report to track the fix can be found at the following link:


    Thank you! Definitely getting closer. I was able to compile the driver (compiled as SU not SUDO) and now on the Windows side I can see all my USB devices. However, when I try to share, it just spins for about 15 seconds and then errors out. After compiling, I did restart the nxserver and the entire machine.

    If I attach a USB device to the Linux side, I do not see it on the Windows side strangely enough. I’ve tried USB 2.0/3.0 drives.

    lsmod | grep nxusb     never returns anything.

    I’ve attached the logs from both sides but no nxusb.log is created on the Linux side.

    Thanks again for the help!


    Hello, could you also include system logs using journalctl command from your Linux machine? It would help a lot.



    I’ve rebooted the machine, tried sharing a USB drive (which failed) and then captured the journalctl logs.

    Thanks for the help!


    Could you please try to load nxusb module by using the command “insmod -v /usr/NX/bin/drivers/nxusb.ko/” and send us the output?

    Thanks a lot


    Sorry for the delay. Here is the output…

    sudo insmod /usr/NX/bin/drivers/nxusb.ko
    insmod: ERROR: could not insert module /usr/NX/bin/drivers/nxusb.ko: Required key not available


    Try to disable Secure Boot in your VM settings.

    Alternatively, you can do this using mokutil. To do so, run these commands:

    sudo yum install mokutil
    sudo mokutil --disable-validation

    Hope it’ll help


    Try to disable Secure Boot in your VM settings.

    Yep, that did it! I disabled the secure-boot option on the VM side and both remote and local USB sharing started working.

    Thank you for your help!!


Viewing 11 posts - 1 through 11 (of 11 total)

This topic was marked as solved, you can't post.