Windows 11 client closes

Forum / NoMachine for Windows / Windows 11 client closes

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #44964
    CTA
    Participant

    On other 2 laptops with Windows 11 home with NM 8.3 and 8.8 free was working well with Linux and other Windows 11 home.

    I can’t use the NoMachine 8.8 free on my main PC with windows 11 pro to check Linux Mint 21 xfcx with NoMachine 8.8 free and or other laptops with 8.8 free.

    The NM just kept closing the client when I am trying to connect to other devices. I tried both old version 8.3 free and new 8.8 free and it didn’t help.

    Can you please help me to point to the issue? Which log do you need?

    #44990
    Britgirl
    Participant

    This may have happened after a graphics driver update. We suggest to disable hardware decoding on the client. First exit the Player on the machine you are connecting from by right clicking on the !M icon in the sytem tray and clicking Exit Player.

    Edit %USERPROFILE%\.nx\config\player.cfg and set:

    <option key=”Enable hardware accelerated decoding” value=”false” />

    Then create a new session and check if it helps.

    If not, set that key to:

    <option key=”Enable hardware accelerated decoding” value=”disabled” />

    and create a new session.

    The first setting disables the use of HW decoding but the codec library is still loaded, while the second settings
    disables completely the HW decoding and cannot be set via UI.

    Let us know result of tests. If it works,  it would be useful to know some hardware details so we can investigate internally. Which is the client side computer model, the graphics adapter name and the driver version?

     

    #44993
    CTA
    Participant

    I have tried to disable HAD from the GUI setting and didn’t work…. and use “false” in the notepad too and not worked either.

    ANYHOW… disable¬† in the notepad seems to be working for now. I have to wait for a few times to play around with NM and see if I encounter similar problem.

    For now… thank you for a solution that I struggled to find for a while.

     

    My pc is 7900x on b550 tomahawk with g.skill trident at 6k mhz, 7900 xtx (latest version) and 1gb m.2.

    Connected to other device that is AMD 3750H with vega gfx

     

    #45012
    Britgirl
    Participant

    I’ve just edited my previous reply to show that you must exit the Player (!M icon in tray, right click, Quit Player), then make the changes suggested, then you can restart the session.

    We’ll keep this topic open for a while. If you encounter the problem again, let us know.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.