Windows client OpenGL issue connecting to Linux Server with Nvidia GPU

Forum / NoMachine Terminal Server Products / Windows client OpenGL issue connecting to Linux Server with Nvidia GPU

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #47469
    timokoo
    Participant

    We have a NoMachine Linux Server 8.2.3 (in Centos 7) with NVIDIA GeForce RTX 3090 Ti card. We have installed the Nvidia driver to the server.

    When runing locally or with physical desktop everyting works as expected, but when connecting with NoMachine virtual desktop from windows host, OpenGL vendor is VMware, and more essentially version is 2.1 Mesa 18.3.4.

    From glxinfo | grep OpenGL:

    Our software where this card is needed requires OpenGL version 3.2 or higher.

    When connecting with physical desktop the glxinfo | grep OpenGL gives the following: (image missing)

    Is there a way to get the OpenGL to use the installed NVIDIA drivers when connecting with Virtual Desktop?

    #47475
    Britgirl
    Keymaster

    Can you submit your image as an attachment please (it’s not possible to paste images in to the field for text). Thank you.

    First you need to enable VirtualGL which is required so that you can view OpenGL accelerated applications. There is an article in our knowledge base with instructions and tips on how to set up your NoMachine server to use VirtualGL.

    https://kb.nomachine.com/AR05P00982

    It’s a good idea to update to the latest version if possible as well.

    #47476
    timokoo
    Participant

    Hi,

    Yes, got it working! I updated the server to latest versio (8.11.), installed virtualgl and enabled it

    /etc/NX/nxserver –virtualglinstall

    /etc/NX/nxserver –virtualgl yes

    and disable/blacklist the nvidia modules from kernel

    rmmod nvidia_drm nvidia_moddeset nvidia

    Thank you!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.