Windows client -> Ubuntu server no recognising Windows key

Forum / NoMachine for Linux / Windows client -> Ubuntu server no recognising Windows key

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #47073

    I’ve just installed NoMachine and am trying to connect from player running on Windows to server running on Ubuntu. I’ve got player in fullscreen mode with capture mouse and keyboard options check and active grab enabled in my client config file. I use the Windows key on Ubuntu to switch desktops but if I press Windows+3, for example, only 3 is pressed on the server. What can I do to track down why the Windows key isn’t being forwarded?


    Many thanks


    We tested on the fly and can’t reproduce. With activegrab enabled, the Windows+3 keys are intercepted and show us the 3rd application running on the remote desktop. In our case, it’s the file explorer.

    Can you start the player from a terminal instead like this?
    /usr/NX/bin/nxplayer --activegrab


    I started from Terminal (just on Windows) with --activegrab and it’s still the same. I did a little investigating and it looks like the keyboard mapping is way off. Other keys are also not working. E.g. the arrow keys are coming out as Print, Alt_R and Super_R. I eventually found the Super_L key on the End key. How is the mapping calculated.

    I’m using an external keyboard to my laptop and I am running the i3 window manager on the Ubuntu server if that’s helpful


    Server reboot seems to have fixed it for the moment.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.