Windows7 to Windows7 – Authentication issue

Forum / NoMachine for Windows / Windows7 to Windows7 – Authentication issue

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #6694

    Hi there…

    I am trying to connect from windows7(machine A) to windows7 (machine B) with my credentials but i get the following error:

    “Authentication failed.please try again. When joining a domain, don’t forget to specify the user name as domain\user.”

    It looks like there is a typo in my password, but i am pretty sure that it is the right one.

    I have tried digging into this, so i opened up the Task Manager on machine B (check the attachments), and found 2 running processes for NoMachine server!

    And i found only one process running for NoMachine server on machine A.

    I don’t know if that’s okay, but that looks weird.

    BTW: I can connect from machine B to machine A successfully but the other way is failed, so i think that i have problem in the server on machine B.

    Note: Both machines have the latest version of NoMachine (4.4.12).

    Could anyone help me to get through this problem?!

    Thanks in advance,




    Hello ammar,

    I would like to see more detailed list of NoMachine processes.
    In Task Manager click on ‘View’, choose ‘Select columns’ and check ‘Command line’ option. Take screenshot of the list of processes as you did before, including content of ‘Command line’ column. Gather the logs following this guide:
    Next, please restart nxserver. If the problem persists, gather the logs again. Send logs and list of processes to forum[at]nomachine[dot]com even if the problem is gone after restart.

    • This reply was modified 9 years, 3 months ago by Cato.
    • This reply was modified 9 years, 3 months ago by Britgirl.
    • This reply was modified 9 years, 3 months ago by Britgirl.
    • This reply was modified 4 years, 6 months ago by Britgirl.

    Hi FooBar,

    Thanks for your reply.

    The problem still exist after restarting the server.

    I have restarted the server by the following steps:

    1-click the gray icon of NoMachine in my toolbar, and select browse connections.

    2-click the preferences button.

    3-click the connections button.

    4-Turn the Connections button OFF.

    5- After a while turn it back to ON.


    Is that procedure true?


    There is one important thing i forgot to mention before, That the 2 processes of NoMachine server appear when i am trying to connect from the another machine (machine A). But when i restart the NoMachine server following the above steps, i get only one server process, and again when trying to connect, another server process comes up!!! an so on.


    I have sent the screenshot (with command line column) after restarting the server and the compressed log folder to the mentioned e-mail.

    Thanks a lot.


    Hello ammar,

    Logs indicate that Windows does not recognise account, you’re trying to use during NoMachine connection.

    There are two possible reasons of such behaviour which are known to me:

    1. You changed your account name and you’re trying to use new username.
    Check this thread: for reference.

    2. You’re trying to use domain account.
    If this is the case, you need to provide username in one of two following formats:
    ‘<username>@<domainname>’, or ‘<domainname>\<username>’.

    If you’re 100% sure that none of these applies to you, and you use administrator account for connection, do the following:

    1. Physically log on Windows account you’re trying to use for NoMachine connection.

    2. Click on grey NoMachine icon in toolbar. Select ‘Show the server status’, click on ‘Server preferences’.

    3. Click on small padlock icon in the bottom left corner.

    4. Provide the same credentials you’re using for NoMachine connection.

    Let me know, if you’re able to unlock the padlock. List of processes you sent looks ok, however, these are instructions to properly restart nxserver:

    1. Open command line as administrator. Open Windows ‘Start’ menu, type ‘cmd’ in search box, click right mouse button on ‘cmd’ icon,
    click on ‘Run as administrator’.

    2. Enter bin subdirectory of NoMachine installation dir: ‘cd <path_to_NoMachine_installation_dir>\bin’. Run ‘nxserver –restart’ command.


    Hello FooBar,

    Thanks a lot, it works!

    Yes,I have changed my username, so i was using the new one, but when i used the old one it works!

    i have found my old username in the following path:

    C:\Users ———> for windows 7

    I am really grateful to you and your fast and professional help ^_^

    I am glad to say”The problem is SOLVED”.

    Thanks a lot,



Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.