Write permissions with connected device

Forum / NoMachine Terminal Server Products / Write permissions with connected device

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #14879

    Greetings: we’re trying to evaluate if the Terminal Server is a suitable product for our team.

    Summary: Users encounter a permissions issue when a Windows 7 client connects a local disk (C:\) and tries to overwrite an existing file on C using thunar or nautilus or other GUI-based applications.

    Steps to reproduce:

    1. Use Windows 7 NoMachine Enterprise Client to connect to Ubuntu 16.04 terminal server and start XFCE desktop.
    2. Connect local disk (C:\) (now mounted on remote server at /home/remoteuser/Desktop/C)
    3. Use thunar or nautilus to copy file from remote server to /home/remoteuser/Desktop/C (use copy-paste)
    4. Repeat the above step, attempting to overwrite the file (use copy-paste or drag-drop).

    Actual results: Permission denied to overwrite file: “Error renaming temporary file. Permission denied.” (see attached image)

    Expected results: File should be overwritten.

    Other notes: I can confirm that I have read-write permissions to the file and also overwriting files through the command line copy (cp) is successful. Deleting files on the connected disk using thunar or nautilus is successful. Certain text editors (gedit, kate) encounter a permissions issue after editing and trying to save a file on the connected local disk; other text editors (atom) have no problem.

    NoMachine product information: NoMachine Terminal Server Evaluation – Version 5.2.21 on Ubuntu 16.04 64-bit server. Client is NoMachine Windows Enterprise Client, Windows 7, connecting to an XFCE desktop.




    Hi benzipper

    After investigation we found out that source of that problem is nautilus itself.

    To be more specific nautilus + mounted disk from windows. It can affect various file browsers and few text editors.

    Nautilus has a specific way to overwrite files, which is not always compatible with overwriting files on mounted devices.

    It’s a known bug affecting multiple Ubuntu users and unfortunately it’s not solved yet.

    You can track it here:



    From our side we cannot provide solution for your problem other that you already found out :

    – replacing files through console

    – deleting and then coping files through file browser.

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.