X11 colors when using NX

Forum / NoMachine for Mac / X11 colors when using NX


Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #11616

    I’ve recently changed to using NX on my Mac to access my Linux box. I used to SSH from my Mac to my Linux box to display all the Linux windows back onto my Mac laptop, but every time I needed to take my laptop to a meeting I needed to disconnect it from the network at at that instant all the X11 windows blew up and I lost everything. I’m now using NX because after a network disconnect and reconnect all my X11 windows have persistence. This is a glorious feature – I can pick up right where I left off when I get a new network connection!

    Anyway, in the SSH method I had some colors set in my .Xdefaults file. I needed to do “xrdb -merge ~/.Xdefaults” once to make it all work, but thereafter all my color preferences were respected. Now that I’m using NX, I can’t get that to work anymore. In my NX config file I have the line:

    <option key=”Command line” value=”/usr/bin/xterm” />

    and once I get to that terminal window after starting NX I can type in “xrdb -merge ~/.Xdefaults” before I run my CAD tools, but the resultant windows do not come up using all the modified colors.

    Any ideas on how to make this work?


    Where is your .Xresource located (Linux box or Mac)?

    Do you mean to use .Xdefaults colors in CAD tools or in Xterm only?

    May I have a look of you .Xdefaults?


    Thanks for responding. First off – I’m not very X11 literate so please forgive me if I’m not hitting the mark with my answer.

    On my Mac I have just done a standard install of XQuartz from https://www.xquartz.org. There is no .Xresource file located in my Mac’s home directory, although it may be elsewhere based on the XQuartz installation. There is also no .Xresource file located in my linux box’s home directory.

    I start the CAD tools from the xterm window that comes up after starting nx, so the cadtools inherit the .Xdefaults stuff. My .Xdefaults file contains the following (and I’m mostly interested in setting the background color to white):

    ! This is the only line in most peoples .Xdefaults file

    Dtwm*VCLSalFrame*secondariesOnTop: True

    ! The following are for changing colors within Cadences schematic editor

    ! After editing this file, do the following command:

    !       xrdb -merge ~/.Xdefaults

    Opus.editorBackground:  white

    Opus.dragColor:                 red

    Opus.selectColor:               red

    Opus.highlightColor:    red

    Cmdtool.MaxLofFileSize:         1000000

    Mouse.Multiclick.Space:         10



    OK – this is embarrassing. It seems to be working now – I have the colors I want. Not sure exactly what I did right during my debugging, but until I can retrace my footsteps I think it’s best to withdraw my post. Sorry for the bother.


    No problem.

    Where I wrote .Xresource I meant .Xdefaults, sorry.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.