Xcode does not react to mouse drag via NM

Forum / NoMachine for Mac / Xcode does not react to mouse drag via NM

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #30080


    Firstly – I have to say thank you for making NoMachine. I’m using it on a Raspberry Pi to connect to a Mac laptop, and the performance (over gigabit ethernet, 1900×1200) is essentially as good as using it directly.

    The one and only issue I’m having is with Xcode, Apple’s official IDE. It includes a mini-map view, as you can see on the right of this screenshot:

    Xcode minimap

    Normally, you can drag a highlighted region of this mini-map to quickly scroll your source files. This works in VNC (and locally, of course), but curiously not through NoMachine.

    I’ve tried this from my Raspberry Pi, as well as my iPad. Both have the same issue. So I’d guess it’s something to do with how the Mac side communicates the mouse behaviour to the system.

    – Server: 6.12.3 (latest), free version. macOS 10.15.6 (latest), Xcode 12.1 (latest)

    – Client: 6.12.3 (latest), free version. Linux Ubuntu 20.04.1 aarch64 (Raspberry Pi 4 8GB).

    Other kinds of dragging (e.g. selecting text) work as expected. Mini-maps in other editors (e.g. Sublime Text) also work as expected, but Xcode is not replaceable as it’s Apple’s official IDE and required for building AppStore apps.

    I’d really appreciate if you guys could investigate it. Thanks a lot, and keep up the great work!



    please try to add the following key in the /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfg file on the server machine:

    DisplayServerExtraOptions "-oldeventapi 1"

    Restart NoMachine and see if anything changes.


    Yes, I can confirm that that works, thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.