Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • in reply to: Are my settings for connecting over the internet ok? #39367

    Accidentally clicked the log away. In the interest of science, I tried again. Seems the exact same log:

    NX> 162 Disabled service: nxserver.
    NX> 162 Disabled service: nxnode.
    NX> 162 Disabled service: nxd.
    NX> 111 New connections to NoMachine server are enabled.
    NX> 161 Enabled service: nxserver.
    NX> 161 Enabled service: nxnode.
    NX> 161 Enabled service: nxd.

    Here you have another read-out ofsudo lsof -i -P -n | grep LISTENnow that everything works:

    systemd-r    589 systemd-resolve   13u  IPv4   26493      0t0  TCP (LISTEN)
    kdeconnec   1561              xx   17u  IPv6   37338      0t0  TCP *:1716 (LISTEN)
    nxplayer.  26147              xx  22u  IPv4  255667      0t0  TCP (LISTEN)
    cupsd     111376            root    6u  IPv6  737692      0t0  TCP [::1]:631 (LISTEN)
    cupsd     111376            root    7u  IPv4  737693      0t0  TCP (LISTEN)
    nxserver. 173453              nx   20u  IPv4 1417331      0t0  TCP (LISTEN)
    nxd       173555              nx    3u  IPv4 1417358      0t0  TCP *:4000 (LISTEN)
    nxd       173555              nx    4u  IPv6 1413803      0t0  TCP *:4000 (LISTEN) 173581              xx   15u  IPv4 1413818      0t0  TCP (LISTEN) 173581             xx  16u  IPv6 1417360      0t0  TCP [::1]:7001 (LISTEN) 173581              xx   17u  IPv4 1417361      0t0  TCP (LISTEN)
    nxclient. 173602             xx   6u  IPv4 1413830      0t0  TCP (LISTEN)
    nxserver. 173828              nx   10u  IPv4 1415919      0t0  TCP (LISTEN) 173860             xx   16u  IPv4 1413883      0t0  TCP (LISTEN) 173860              xx   17u  IPv4 1411803      0t0  TCP (LISTEN)



    in reply to: Are my settings for connecting over the internet ok? #39364


    Britgirl email:

    “Hi, thanks for all the information and your patience so far.

    “In the Ports panel, nxd is not running. Which means that nxnode is ‘stopped’. So something went wrong, somewhere. I assume you’ve not changed anything in the server configuration file, for example changed any keys in there or inserted anything by hand, or physically stopped the nxd process?

    “So, first we need to get nxd running. Have you already done a restart? Let’s try again anyway. You can try by entering the Ports panel again and clicking on the NX service to configure it via GUI. If that fails, let’s try from a terminal:

    "sudo /etc/NX/nxserver --restart

    “Have you noticed that nxd stays running but then stops? I ask because you said in previous replies that on LAN you can connect ok. This indicates that at some point nxd was actually running. But for some reason now, it’s not. This might explain the two types of error, instead of just one. …”

    Ok, after reading that my NX Node stopped, i tried the LAN connection: it didn’t work for the first time ever! Suspecting I may have accidentally unticked “start the automatic services at startup” (when “the machine starts” -> laptop or the No Machine server/app??), i checked it again, rebooted the No Machine app on the laptop, and got rid of all the extra port forwards…

    Still nothing. Now LAN also doesn’t work!

    So I tried to command you gave: sudo /etc/NX/nxserver --restart


    It said “disabled” a few times. Then went to “enabled”. Next thing you know both LAN and also WAN work. That’s the first time WAN works (had to click through an “authenticity of host … can’t be established. … Are you sure you want to continue?”).

    In other words, it’s still a mystery. But it works. I just have to store that sudo command somewhere I guess.

    Thank you.




    in reply to: Are my settings for connecting over the internet ok? #39277

    Nope. Threw open all ports for SSH (22-22) and NX (24000-4000) on both the primary ADSL modem/router as the secondary more advanced router (including the 4411 UDP media port).

    By now NoMachine on my phone can see it involves a Linux machine, but under SSH it says, “Error is 100: Connection timed out”. Under NX it says, “Error is 111: Connection refused”.

    Maybe you understand the issue. I don’t. Maybe it’s something with the proxy. Maybe it’s the provider. I’m out of ideas.

    in reply to: Are my settings for connecting over the internet ok? #39276

    Well, still doesn’t work. Even installed a secondary router with UPnP support and have it alternately enabled and disabled. Still no port visible in the NoMachine server. Port forwarding 24000 (or another, mirrored in the app): no effect. Error 111, always. Local network via phone *again* works fine: instantly it is also seen that this is a “Linux Mint 20.3” laptop.

    ‘There is no need to enter the ‘Configuration’ panel to configure a proxy unless you know what the proxy details are.’

    There is no separate ‘Configuration’ panel; only an ‘Advanced’ section. If that is what you mean, details matter when you write/give instructions. This adds confusion.

    Why don’t I need to enter a proxy? Like 99% of people I sit behind a router (a proxy) on a “residential broadband connection. Your app even says:

    ‘Choose this if you are connecting to a computer on your same LAN or if you are on a residential broadband connection.’

    When I’m on the same LAN, proxy doesn’t have to be used. It works fine without it. So why does it say in your app it needs a proxy to be filled in? What’s the relation to the vague description ‘residential broadband connection’? Sounds like a router of sorts.

    But my router of course doesn’t have an external username and password. So maybe we’re talking more about a corporate network here or something. I can just make no sense of these descriptions.

    I also see additional ports being used by the app? Do I need to forward those too? 4411, 8080?

    Hence, the comment:

    The Welcome panels illustrate what to do.

    I do not agree with.

    Anyway, I can’t get the app to work remotely, also not a new router.

Viewing 4 posts - 1 through 4 (of 4 total)