Forum Replies Created

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • in reply to: Install script error #35468

    This is not an issue specific to elementary or any os.  Because of the way you check for permission in your script if s bit is set over x then the script fails even though s indicates executable as well.  It needs to check for either is all.   You can’t assume it will only be x.  (line 4010)

    if [ $(“${ECHOCOMMAND}” “${dirperms:4:1}”) != “r” ] || \
    [ $(“${ECHOCOMMAND}” “${dirperms:6:1}”) != “x” ] || \
    [ $(“${ECHOCOMMAND}” “${dirperms:7:1}”) != “r” ] || \
    [ $(“${ECHOCOMMAND}” “${dirperms:9:1}”) != “x” ]
    printMsg “It seems that you are trying to install this package in a directory without proper permissions. Please try to install it in a different” 0
    printMsg “directory or change permissions. The installation directory should” 0
    printMsg “have at least 555 permissions set.” 0

    exit 1

    like this

    [ $(“${ECHOCOMMAND}” “${dirperms:4:1}”) != “r” ] || \
    ! ( [ $(“${ECHOCOMMAND}” “${dirperms:6:1}”) = “x” && [ $(“${ECHOCOMMAND}” “${dirperms:6:1}”) != “s” ]) || \
    [ $(“${ECHOCOMMAND}” “${dirperms:7:1}”) != “r” ] || \
    ! ( [ $(“${ECHOCOMMAND}” “${dirperms:9:1}”) = “x” && [ $(“${ECHOCOMMAND}” “${dirperms:9:1}”) != “s” ])

    also you might consider using stat like so instead of checking directly for x/s/r

    stat -c ‘%a’   <directory or file>


    in reply to: Initially connection refused 111 #14798

    No using the server’s ip address as opposed to it’s hostname does not resolve the issue.

    It takes about 4 minutes until the connection can be established…

    What would be causing this delay?



    in reply to: Ctrl combinations ignored #14783

    Ok,  I did as you suggested and yes the NoMachine player window supersedes the client OS keyboard.

    Not that I needed that gnome mouse feature but one can now leave it on if desired.


    is there and  activegrab key that can be set in the player.cfg file??

    That would be easier than an option on the comand line.

    in reply to: Ctrl combinations ignored #14616

    I discovered the issue.

    If you are using a gnome based client it has a setting ” show position of cursor when control key is pressed”  this setting grabs the cntrl key keypress before it can be sent to the NoMachine host.   Just disable this feature in the mouse settings and all is well.

    Also it can be diasabled directly in the gconf settings.  see these two webpages.

    ctrl-key-not-working-in-vnc (link removed)

    how-do-i-use-the-gconf-editor (link removed)

Viewing 4 posts - 1 through 4 (of 4 total)