Forum Replies Created

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • timatgca

    I don’t know where .xsession-errors is, neither can I find the X logs.

    I found this in journalctl -e


    Jun 09 09:48:31 keynes /usr/lib/gdm3/gdm-x-session[28565]: _XSERVTransMakeAllCOTSServerListeners: server already running
    Jun 09 09:48:31 keynes /usr/lib/gdm3/gdm-x-session[28565]: xorg-server 2:1.20.8-2ubuntu2.1 (For technical support please see http://www.ubuntu.com/support)
    Jun 09 09:48:31 keynes /usr/lib/gdm3/gdm-x-session[28565]: (II) The server relies on udev to provide the list of input devices.
    Jun 09 09:48:31 keynes /usr/lib/gdm3/gdm-x-session[28565]: Fatal server error:
    Jun 09 09:48:31 keynes /usr/lib/gdm3/gdm-x-session[28563]: Unable to run X server
    Jun 09 09:48:57 keynes gnome-shell[27758]: gnome-shell: Fatal IO error 11 (Resource temporarily unavailable) on X server :1002.


    Hi, possibly the ubuntu bug report will add some clarification. I see by the response that you may not understand the issue.

    The problem is that physical sessions can not log in after a virtual session via NoMachine has happened because the input devices (mouse and keyboard) do not appear to be available to the X server.

    If the NoMachine remote session was a “desktop share” session because the user is already logged in to the server, then there is no problem.

    To reproduce the bug you must have a virtual desktop session (that is, the user is not logged on to the server locally, then connect to the Nomachine Workstation server)

    Terminate the session, and then attempt to physically log in.

    Whatever happens, it requires a kill of X to fix. However, while this problem exists, it only affects a local user, it is possible to have subsequent nomachine virtual server sessions.

    I hope this helps you reproduce it



    This is the ubuntu bug report I mentioned:




    The NoMachine sessions work fine.

    The problem is local.

    I have to kill X to get it working again .,. Restarting gdm3 is not sufficient, neither is restarting the NoMachine server.

    There is an Ubuntu bug report with the same problem (from 18.04)

    I will see if I can find errors in a log file.

    in reply to: Control keys not working for copy&paste #20944

    Yes, I had “show pointer when control key is pressed” option, enabled by Gnome Tweaks (I am using ubuntu 18.04)

    When I turned this off, control key and function keys are passed through to the remote desktop session. Good catch, I would never have thought of this. So now there are two solutions.

    I think it may be worthwhile mentioning this with a bit visibility 🙂



    in reply to: Control keys not working for copy&paste #20932

    I fixed this by starting with –activegrab

    e.g. /usr/NX/bin/nxplayer –activegrab

    although I also made a new launcher for gnome that starts it like this.

    I am connecting to NoMachine Workstation, gnome desktop, both server and client are ubuntu 18.04 and I have the Enterprise Client.

    So this completely fixes the problem, it seems. I wonder why this option is not much publicized when it makes such a difference?



Viewing 6 posts - 1 through 6 (of 6 total)