Black screen after uninstalling NoMachine from Nobara

Forum / NoMachine for Linux / Black screen after uninstalling NoMachine from Nobara

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #48208
    viirin
    Participant

    I installed NoMachine, realized it wasn’t going to do what I wanted, and then uninstalled it. Upon doing so and rebooting the system I booted to a black screen with a mouse pointer.

    I spent some time googling and found people reporting the same issue and a couple fixes that worked for people in different distros. Sadly, those fixes don’t work for me in my own distro. What did allow me to boot back up was simply booting into rescue mode and reinstalling NoMachine, which returns my system to working order.
    I am running Nobara, a Fedora based distribution running KDE.

    #48220
    Britgirl
    Keymaster

    This is a bug we are aware of and it’s reported here: https://www.nomachine.com/TR04V11131, the fix is planned for the next update. In the meantime, please follow the instructions I posted here: https://forum.nomachine.com/topic/no-gpu-after-uninstalling-nomachine#post-47927, and I’m pasting them here as well:

    As user root

    Make a copy of the following files

    /usr/NX/scripts/vgl/vglserver_config
    /usr/NX/scripts/vgl/vglgenkey
    

    making sure to place them in the same folder

    – Uninstall

    – Execute /vglserver_config -unconfig

    – Reboot

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.