Can’t get HW encoding working [Fedora 37, intel UHD P630]

Forum / NoMachine Terminal Server Products / Can’t get HW encoding working [Fedora 37, intel UHD P630]

Viewing 7 posts - 16 through 22 (of 22 total)
  • Author
  • #44020

    Check your inbox Timo.


    I’ve sent you a new debug library Timo 🙂



    in case it may be relevant (changelog gave no hints in that regard though),
    I updated the server (and client) to 8.5.3 but the issue still persists as decribed.


    Hi Timo, so here’s where we are.

    We don’t have your same card, so debugging ourselves is difficult. We use the Intel mediasdk mfx library for Intel QuickSync acceleration and for your specific problem it fails right on the start when we try to initialize the mfx session. It returns every time the MFX_ERR_UNSUPPORTED error, this is what we can see in the logs.

    We’ve put together another debug library for you to test (this is our last one), when you have a chance please try it and send the logs as before. I’ll send the link via email as before, so check your inbox.

    After that, what we can suggest, if you are able to, is that you test the mfx library with your own set-up by building it yourself.

    Here is the link to the library

    The instructions for building and running it are here: and

    We’ve checked the instructions, you’ll need to install additional development pacakages for libva and libdrm (libva-devel and libdrm-devel). If there is anything missing, the building process tells you what packages are missing, so you should be able to follow along. Tell us whether building it yourself and then running a sample encoder it works or not.


    Following on from the logs that you submitted from our last debug library, can you send us the output of ls -l /dev/dri?


    For the Intel UHD P630 machine

    $ ls -l /dev/dri/
    total 0
    drwxr-xr-x. 2 root root         80 Jun 13 21:31 by-path
    crw-rw—-+ 1 root video  226,   1 Jun 13 21:31 card1
    crw-rw-rw-. 1 root render 226, 128 Jun  9 18:43 renderD128

    The server housing the Intel Arc 380 (DG2)


    did not exist there.
    I guess, that’s why you were asking.

    Reason is the terrible Intel Arc that behaves erratic on boot.
    A power cycle solved that.
    (We have two of them, that behave identical. And you can find
    plenty of bug reports of that sort. So it’s certainly not a hardware error.)
    For that matter I suggested to focus debugging on the P630 first
    as it also fails for encoding but doesn’t come with the additional
    woes of the Intel Arc (on Linux).

    I’ll send you the logs for the DG2 properly initialized.


    The logs from the arc 380 continue to show the MFX_ERR_UNSUPPORTED error which we print as:

    Info: Intel Quick Sync H.264 acceleration is not supported.
    Info: Please consider updating your Intel drivers.

    It would have been useful to know the outcome of installing/building mediasdk using the other ways we mentioned in the articles provided for comparison. As things stand, it is likely that the issue is with the Linux drivers.

Viewing 7 posts - 16 through 22 (of 22 total)

This topic was marked as solved, you can't post.