Ctrl->Cmd key mapping doesn’t work from Linux to Mac

Forum / NoMachine for Mac / Ctrl->Cmd key mapping doesn’t work from Linux to Mac

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #46969
    mkschmitty
    Participant

    Hello,

    I’m running NoMachine 8.11.3, from Linux (CentOS 7.9, GNOME Version 3.28.2) to MacOS Sonoma 14.1.1.

    When I remote in to the Mac from my Linux workstation, Cmd-X (Cut) Cmd-C (Copy) Cmd-V (Paste) and Cmd-Z (Undo) do not work in any program on the mac.

    In a mac command-line terminal, Ctrl-C, and Ctrl-Z work as they should.  But otherwise, any software on the mac that requires the command key for cut, copy, paste, undo etc. does not work.

    Any ideas of how to fix this?

    ps.  If I run in reverse, Mac to Linux (with keyboard, mouse and monitor hooked up to the Mac), Cmd-X, Cmd-C, Cmd-V, Cmd-Z work on the mac, and Ctrl-X, Ctrl-C, Ctrl-V, Ctrl-Z work on Linux.

    Thank you for your help

    #47001
    aguar
    Participant

    I’m running into the same issue.

    Running NoMachine 8.11.3 on Ubuntu 22.04.3 GNOME 42.9 connecting to an M1 Pro MacOS Sonoma 14.3.1.

    Has this issue been reported anywhere outside this forum?

    #47023
    Britgirl
    Participant

    There are a couple of similar topics in the forum about this already, one of which is:

    Clipboard between Mac and Ubuntu rarely works

    This is a problem related with how Gnome works. SuperKey, which on macOS is mapped to Cmd key, is a special key which works with high priority. You should enable activegrab as described in that link to the post above.

    The article here provides the full explanation and workaround:

    How to send ‘Option+Click’ from Linux to macOS
    https://kb.nomachine.com/AR10Q01058

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.