No hardware decode on Kubuntu 22.04 + GTX 1060 6GB

Forum / NoMachine for Linux / No hardware decode on Kubuntu 22.04 + GTX 1060 6GB

Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • #44006
    Ilgaz
    Participant

    Hello

    Here is the output of the commands

    vainfo --display drm
    Trying display: drm
    libva info: VA-API version 1.18.0
    libva info: Trying to open /usr/lib64/dri/nouveau_drv_video.so
    libva info: Found init function __vaDriverInit_1_18
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 1.18 (libva 2.18.1)
    vainfo: Driver version: Mesa Gallium driver 23.0.2 for NVAC
    vainfo: Supported profile and entrypoints
    VAProfileMPEG2Simple            : VAEntrypointVLD
    VAProfileMPEG2Main              : VAEntrypointVLD
    VAProfileVC1Simple              : VAEntrypointVLD
    VAProfileVC1Main                : VAEntrypointVLD
    VAProfileVC1Advanced            : VAEntrypointVLD
    VAProfileH264ConstrainedBaseline: VAEntrypointVLD
    VAProfileH264Main               : VAEntrypointVLD
    VAProfileH264High               : VAEntrypointVLD
    VAProfileNone                   : VAEntrypointVideoProc

    for DRVNAME in $(find /usr/lib -name “*drv_video.so” -exec basename {} \; | sed ‘s/_drv_video.so//
    ’); do for DEVICE in /dev/dri/* ; do LIBVA_DRIVER_NAME=$DRVNAME vainfo –display drm –device $DEVICE 1>/dev/null
    2>/dev/null ; [ $? -eq 0 ] && echo “$DRVNAME $DEVICE” ; done ; done 2>/dev/null | grep -v dummy

    Unfortunately, no output has been shown as a result of that command.

    #44016
    Britgirl
    Participant

    for DRVNAME in $(find /usr/lib -name "*drv_video.so" -exec basename {} \; | sed 's/_drv_video.so//'); do for DEVICE in /dev/dri/* ; do LIBVA_DRIVER_NAME=$DRVNAME vainfo --display drm --device $DEVICE 1>/dev/null 2>/dev/null ; [ $? -eq 0 ] && echo "$DRVNAME $DEVICE" ; done ; done 2>/dev/null | grep -v dummy

     

    did you run as I have pasted above? We noticed that in your output shows -display drm -device... and not --display drm --device... (my fault maybe because I didn’t put my text in tags, since corrected)

    If that does not produce any output, you can try with “find /usr/lib64......” instead of “find /usr/lib.....

    Provided there is some output you should then

    1. edit /usr/NX/bin/nxplayer
    2. add line

    LIBVA_DRIVER_NAME=name

    where ‘name’ is the driver that shows in the output. This instructs va-api decoder to use that specific driver. You should place it before the line:

    exec "$NX_SYSTEM/bin/nxplayer.bin" "$@"`

    3. Then start your NoMachine session. If it does not work, the ~/.nx/R-*/session directory will contain more info.

    #44023
    Ilgaz
    Participant

    Hello,  thanks again for caring.

    When I issue the command with the lib64 path under openSUSE Tumbleweed:

    nouveau /dev/dri/card0
    nouveau /dev/dri/renderD128
    r600 /dev/dri/card0
    r600 /dev/dri/renderD128
    radeonsi /dev/dri/card0
    radeonsi /dev/dri/renderD128
    virtio_gpu /dev/dri/card0
    virtio_gpu /dev/dri/renderD128

    So I added the line (I run nouveau/nvidia)

    LIBVA_DRIVER_NAME=nouveau

    When I launch the nxplayer.bin and attempt to connect a host it core dumps. I attached the dump file. There are some errors with libva reported in session (log) I am attaching it too.

    #44042
    Britgirl
    Participant

    Logs show that the error seems to be in the GPU pipeline and with nouveau.

    Please try disabling GPU rendering. You can do this by setting the following option key "Enable GPU rendering" value="true"   to falsein player.cfg.

    #44069
    Ilgaz
    Participant

    That setting fixes the crash (coredump) however I get hit by a familiar-looking glitch making the session impossible to interact with. It looks almost exactly the same as the video glitches I saw with Firefox/Wayland. I believe it got fixed with better multithreading on Nouveau, I am actively using video acceleration with Firefox.  https://bugzilla.mozilla.org/show_bug.cgi?id=1658772 . I will inform Nouveau developers about it. Anyway thank you for caring.

    #44123
    Britgirl
    Participant

    Yes, it’s a case for the nouveau developers.

    In the meantime, when connecting with NoMachine you’ll be able to use software decoding instead.

    #44349
    SparkleCoder
    Participant

    My my my…I wish I had seen this thread sooner, as I have some first-hand experience with almost this exact situation and learned a few things during the torturously long debugging of it. I don’t know if this will be of any assistance, but here’s hoping…

    First, I am pleased to inform you that reports of the demise of the vdpau-va-driver package have been grossly exaggerated, haha. It’s actually been reincarnated under a new developer not associated with the Mesa project and is now named nvidia-vaapi-driver. I wish that was the key to solving this whole affair, but I’m afraid there’s more. The code changes that were apparently necessary to solve my issue were only just released in the latest version, which sadly hasn’t been a priority for anyone on the Debian/Ubuntu/KDE packaging teams to push out to the repos.

    That leaves it to you to compile the driver yourself, if you’re comfortable with doing that, or if not then I’m happy to share the packages I built of that latest version for everything from Jammy all the way up to Mantic, which I just uploaded to my PPA in case that was your preference. Naturally, you’ll also want to add the official NVIDIA apt repository to your /etc/apt/sources.list.d directory by placing a file in it ending in .list with deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu2204/x86_64/ / in it, then adding their signing key to /etc/apt/trusted.gpg.d with the command sudo apt-key --keyring /etc/apt/trusted.gpg.d/nvidia.gpg adv --keyserver keyserver.ubuntu.com --recv-keys EB693B3035CD5710E231E123A4B469963BF863CC. Polish it off with a sudo apt update and a sudo apt full-upgrade and if my experience is any guide, you’ll be NoMachine-ing all over God’s creation after a quick reboot. I’m sorry this advice comes so late and hopefully your problem is already long-solved, but perhaps in that case this’ll be of use to the next person to meet this fate. Best wishes to you.

    P.S. The above directions were created with a baked-in assumption that you already have the apt-transport-https and apt-utils packages already installed on your system, as tends to be the case. If that happens not to be so, please install them with sudo apt install before following them. Toodles.

    #44378
    Britgirl
    Participant

    Thanks SparkleCoder for your contribution!

    We’ll make sure we reference your post if others come with the same issue 🙂

    #44475
    Piter Dias
    Participant

    Hi, SparkleCoder. I am the one who opened this thread.

    After adding Nvidia sources, upgrading to 525 driver session, adding your ppa and installing nvidia-vaapi-driver, I still have the same errors using GTX 1060 and software decoder.

    Am I missing some step?

    Thanks in advance.

    Info: Established display connection.
    libva info: VA-API version 1.14.0
    libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
    18408 18595 2023-06-02 20:11:54 693,796 VADecoder/VADecoder: WARNING! Failed to initialize DRM display for device /dev/dri/renderD128 with error 0xffffffffffffffff.
    libva info: VA-API version 1.14.0
    libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
    18408 18595 2023-06-02 20:11:54 693,909 VADecoder/VADecoder: WARNING! Failed to initialize DRM display for device /dev/dri/card0 with error 0xffffffffffffffff.
    Info: H264 support is available.
    Info: RT handler running with pid 18612.
    Info: Forwarded new display connection.
    Info: Display client for channel 9 connected on Fri Jun  2 20:11:54 2023.
    Info: Remote desktop resized to 1920×1080.
    Info: Session window surface configured.
    Info: Changing display mode to ‘viewport’.
    18408 18408 2023-06-02 20:11:54 985,942 ClientSession: Ignore request to create a view without a frame.
    Info: Using H.264 software decoder.

     

     

    #44477
    Piter Dias
    Participant

    Hi. I am almost there. After digging into nvidia-vaapi-driver driver repository on Github I add the following line to /usr/NX/bin/nxplayer, just before exec `”$NX_SYSTEM/bin/nxplayer.bin” “$@”
    export NVD_BACKEND=direct
    export LIBVA_DRIVER_NAME=nvidia`
    Now I have hardware decode but the image is very ugly (see attached) and I see some strange messages in the log. Can someone help?

    libva info: VA-API version 1.14.0
    libva info: User environment variable requested driver 'nvidia'
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
    libva info: Found init function __vaDriverInit_1_0
    libva info: va_openDriver() returns 0
    Info: Detected VA-API NVDEC driver [direct backend].
    Info: Using H.264 hardware decoder.
    10289 10359 2023-06-03 17:35:32 085,898 VADecoder/VADecoder: WARNING! Failed to derive image. Falling back to default image retrieve method.
    10289 10359 2023-06-03 17:35:32 088,237 VADecoder/VADecoder: ERROR Failed to acquire buffer handle. Error was: 20
    10289 10359 2023-06-03 17:35:32 088,280 Failed to pass yuv planes to gpu pipeline. Fallint back to default yuv planes passing.
    #44740
    Piter Dias
    Participant

    Hi, Britgirl. Two weeks ago I sent the logs that you asked me generate. Today I just upgraded to 8.6.1 in both machines (Windows and Linux) but the weird screen showed in last reply remains. Did you have time to check it?

    Thanks a lot.

    #44851
    Britgirl
    Participant

    Hi Piter, we are going to send a debug library, please check your inbox. If you have any questions about the library, simple hit reply to our email.

Viewing 12 posts - 16 through 27 (of 27 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.