Nxplayer fails to open on Win10

Forum / NoMachine for Windows / Nxplayer fails to open on Win10

Tagged: 

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #48386
    biglia
    Participant

    Hi, on Windows 10 machine nxplayer fail to open

    From nxtrace.log:

    Module: C:\Program Files\NoMachine\bin\nxplayer.bin pid 7364
    Thread: 7380 exception 0x6ab, ‘Unknown’
    In: C:\WINDOWS\System32\KERNELBASE.dll at 0x64acba99
    #0  0x0000000064acba99 KERNELBASE.dll(RaiseException)
    #1  0x0000000066aa60a0 RPCRT4.dll(RpcRaiseException)
    #2  0x0000000066aa6064 RPCRT4.dll(RpcRaiseException)
    #3  0x0000000066b2af49 RPCRT4.dll(NdrMesSimpleTypeEncodeAll)
    #4  0x0000000066b2dc70 RPCRT4.dll(NdrClientCall3)
    #5  0x0000000063b7139e wkscli.dll

    already run “dims /online /cleanup-image /restorehealth” and “sfc /scannow”, same error

    Same error on another PC with Windows 10

    Same error with antivirus disabled

    Thanks.

    #48394
    Britgirl
    Keymaster

    Hi,

    did you install just the client i.e Enterprise Client, or is it a client/server product such as the NoMachine free version? If you installed the latter, is the server running correctly and accessible from the system tray?

    When it happens, can you check in the Task Manager if the nxplayer.bin process is running but its window does not open, or is there no nxplayer.bin process open at all?

    It would be useful to see the NoMachine logs from the affected Windows host. Look for the .nx directory, on Windows the .nx folder is hidden. To find it, write the following in the address bar or the explorer, for example C:\Users\your_account\.nx). Also send the full nxtrace.log of that excerpt. Please send everything to forum[at]nomachine[dot]com.

    #48408
    biglia
    Participant

    I’ve NoMachine free version, the icon in system tray is visible but none of nxplayer or nxserver window are opened. In task manager i see device server, node process, nx server and server process.
    When trying to open nxplayer, none process are listed in taskmanager.

    nxtrace.log on my pc is located at C:\ProgramData\NoMachine\var\log

    I’ll send it by email

    #48412
    Britgirl
    Keymaster

    Hi, can you also send us the .nx folder from the user’s home of the Windows computer (typically found in C:\Users\USERNAME\.nx)?

    #48413
    biglia
    Participant

    I not have C:\Windows\Users\USERNAME\.nx

    I’ve only C:\ProgramData\NoMachine and C:\Users\USERNAME\.nx

    I’ll send by email

    #48418
    Britgirl
    Keymaster

    Sorry, my mistake. I’ve corrected the path example I made.

    #48423
    pawelgl
    Participant

    I have exactly the same problem.

    I installed the free version on Win 11 and it works as expected. I then repeated it on 3 machines with Win 10. I restarted them. Unfortunately I cannot connect to any of them. I tried disabling the firewall – no luck.

    Servers are running

    The only way to connect to them is to restart nxserver

    After that it works properly and I can connect to it.

    Thanks,

    Pawel

    #48427
    Britgirl
    Keymaster

    pawelgl, restart is necessary after installing. Do you mean you have to restart the server every time you want to connect to any of the Windows hosts? When it happens, what message is shown? If it occurs again, please submit the logs from both the player and the server machines. To do that, follow the instructions here and then send them to forum[at]nomachine[dot]com. It could be a different issue, and if that’s the case we can create a new topic. Thanks!

    #48428
    Britgirl
    Keymaster

    Biglia, nothing in the logs shows there is a problem in NoMachine, and it’s likely that there is system miconfiguration or something corrupt in the system. You should verify that “wkscli.dll” (Workstation service client) is valid and not corrupted. Also check that there are no multiple copies of the DLL which might be getting hijacked. Is this a corporate-managed PC with particular policies being configured?

    #48429
    biglia
    Participant

    As written above I have already done both the DISM and SFC system checks.
    The PC has no particular policies.
    I have the same problem on 2 PCs.
    I’ve had this problem on one for longer, on the second it always worked at first, then recently it stopped, I can’t quantify the time.

    #48431
    Britgirl
    Keymaster

    Are you able to start Windows in recovery mode and see if player starts?

    it always worked at first, then recently it stopped,

    Could something have changed on your Win 10 PCS recently? An update perhaps? Do you have any physical or wireless devices attached to these Win hosts, if so can you list them? This info will be useful to know to allow us to conduct our own tests and replicate your set-up.

    Also tell us the exact Win 10 version (i.e the version + build number).

    #48437
    pawelgl
    Participant

    Update,

    everything works fine on the local LAN. I found the last laptop with Win10, installed NoMachine, rebooted and it works as expected.

    The problem is when I try to connect to the machines via VPN. I am using tailscale. I tried to connect from home to the machines in the company via the IP address or hostname of tailscale – no luck. Then I repeated this inside the company – both computers are connected to the same LAN and both use tailscale. No connection using local IP address, local hostname or vpn IP address.

    #48434
    pawelgl
    Participant

    Britgirl,

    no problem with the installation. I restarted the machines after the installation. I tried on 3 machines and the problem occurs on all of them. You misunderstood me, the “server restart” in my post is not a restart of the whole machine. It is just a restart of the nxserver. After that, a window appears with raising administrative privileges, I press yes, wait a while and everything works fine.

    #48445
    Britgirl
    Keymaster

    So your issue is different Pawelgl and there should be a separate topic for handling this. Please submit a new one with all the details about your setup, where the PCs are, how you are connecting (through Tailscale) and so forth.

    #48446
    biglia
    Participant

    In safe mode nxplayer starts normally, after reboot it doesn’t work again.

    No hardware change.

    I can’t say about the updates, I can’t quantify the time that has passed since it worked, I don’t use it much.

    Windows version now 19045.4474

    but on another PC used as a test, same version of windows and same updates, nxplayer works fine.

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.