Raspberry Pi 5 not working with NoMachine

Forum / NoMachine for Raspberry Pi / Raspberry Pi 5 not working with NoMachine

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #45936
    srirammacha
    Participant

    I have the new raspberry pi 5 8gb with raspberry os bookworm installed but NoMachine dosnt work with new Pi 5.

    I get this error

    The connection with the server was lost.

Error is 54: Connection reset by peer.

    #46040
    Macrobiotic
    Participant

    It seems to be due to there being no support for Wayland in NoMachine.

    Since Raspberry Pi OS on the Raspberry Pi 5 uses Wayland instead of X11, that is likely to be the cause.

    On some other places I’ve seen mentions that having XWayland will help, but I’m not sure if that’s an option in this case.

    #46044
    Britgirl
    Participant

    Hi, we will be adding support for Raspberry 5 in the next release. At the moment there is the following known issue, also reproducible on RPi5. It’s caused by Wayland indeed. The link to the TR is just below,  with the workaround which is to disable Wayland.

    https://kb.nomachine.com/TR10U11031

    #46045
    Macrobiotic
    Participant

    Hi Britgirl, many thanks for the update.

    Does NoMachine development run on a particular cadence, or do you release it when it’s ready? It would be nice to know how long until the next version.

    #46048
    Britgirl
    Participant

    How often we make a maintenance release generally depends on what tweaks and fixes have been added. It can be once a month or it can be every 2 or 3 months. If you take a look at the Software Updates section, you can see how often we release updates. We are still waiting for the RPi5  devices we ordered, so that’s why we have not officially “added support” yet (i.e we did not add it to the devices in the download section of the website, nor mention it in our latest release announcement). Adding “support for a distro or OS version, or a device” means that we have tried and tested it in our labs 🙂 In the case of RPi boards in general, there is the issue with Wayland, so please use X.org instead.

    #46313
    brianlmerritt
    Participant

    Hi, you don’t need raspberry pi 5, as 4 has the same issue on the latest raspbian os

    #46316
    Britgirl
    Participant

    That’s right. The Trouble Report I linked applies to all RPi boards.

    #46441
    NaN
    Participant

    After changing WaylandModes egl,drm,compositor

    to

    WaylandModes egl,compositor,drm

    in /etc/NX/etc, I don‘t get this error anymore and the connection at least starts.

    But I have two other problems related to keyboard:
    First, the Magic Keyboard doesn‘t work when I apply any changes to the settings during the startup of the session (e.g. set a custom resolution etc.) Only if I set everything up and click „do not ask again“, so the session starts without any questions asked it seems to work.

    Even then I have the problem that in FreeCAD the Shift, Control and Option keys are not detected in Touchpad mode: Usually when setting the input scheme to touchpad one can move the design by pressing Shift at the same time as moving the mouse (no mouse button has to be clicked). And when pressing Option it should rotate the view.
    One can use keyboard commands (0,1,2 etc.) to change the view to front/back/left/right etc. – but often one needs more fine grained control.

    (With [removed] as viewer and the onboard [removed] server turned on all this works without problems (including Touchpad mode in FreeCAD). There I have the problem that the screen turns completely black once I start FreeCAD when I power the Raspberry PI 5 from the iPad. (It works when using an external power supply). Perhaps the power consumption gets too high once the GPU jumps in? NoMachine provides more fps for e.g. video streaming though, so if it would work nicely it would be preferrable to [removed].)

    Any ideas how I could get the control keys to work in FreeCAD?

    P.S.: Using a German layout on the Raspberry Pi. But the Shift/Control etc. keys are at the same position as for the US layout.

    #46471
    Britgirl
    Participant

    Nan, interesting. Are you able to send us the logs before and after having changed the WaylandModes key? To get logs check the instructions here: https://kb.nomachine.com/DT07S00243. You can send them to forum[at]nomachine[dot]com.

    Also, you mention that when connecting from an iPad to the RPi5 and using FreeCAD, those particular keys (shift, control, option) are not working. Are you able to verify if those keys are not working in other applications?

    #46475
    NaN
    Participant

    Regarding the WaylandModes key – this was probably spurious correlation. I changed that key and a system update was running in the background. After reboot NoMachine worked, so I attributed it to the WaylandModes key change.

    But my guess now is that the system update has changed from Wayland to X11 as default. Have manually switched back to Wayland now and tried all three WaylandModes options – without success. So X11 seems to be the way to go for now (and then the value of WaylandModes doesn’t matter, for obvious reasons).

    So good news might be that the newest Raspberry Pi OS might be configured right for NoMachine out of the box – at least I didn’t manually change to X11 at any time. (Well, I installed various libraries and dev tools, including all the stuff needed to compile the latest FreeCAD version – perhaps that has pulled some package that led to a config change?)

    When getting the 54 error a first step might be to do a “sudo apt update && sudo apt upgrade” first, then reboot and then if it still doesn’t work check the first posting of Britgirl with the instructions to disable Wayland in case it is still enabled after that.

    #46490
    oldeflyer
    Participant

    Britgirl,

    RPi4 running Bookworm.  Looked at the Trouble Report link and was not sure which download to get.

    I am running the 32 bit version of the OS due to constraints while using the Mono software.

    I have been running NoMachine on my Linux Mint (Cinnamon) laptop for some time and like the way it works.

    Which version should I try for my RPi4?

    Thanks,

    Wayne

    #46474
    NaN
    Participant

    Hi @Britgirl, thanks for the feedback!
    I just double checked, the Raspberry Pi OS seems to be set to X11 mode by default (I tried to change it and it was already set up like this).

    The magic keyboard is directly connected to the iPad where the NoMachine client runs (it is built into the cover of the iPad). When connecting via a NoMachine Windows client I initially got the same effect, but when activating “grab the keyboard” the modified keys work in FreeCAD – so it is a solution for Windows clients indeed!
    Unfortunately that “grab the keyboard” option doesn’t seem to be available in the iPad client on first sight(?)
    Strange thing is: I can type inside applications on the remote Raspberry Pi and even use Shift to e.g. generate capital letters, press Ctrl+C/V for copy and paste etc. Just Shift+mouse move or Ctrl or Alt + mouse move don’t seem to be supported. Could it be that NoMachine doesn’t transfer the modifier keys like Shift/Ctrl/Alt per se but only combinations as soon as another non-modifier key is pressed when not in “grab the keyboard” mode? That would explain it.
    When connecting any keyboard directly to the Rasperry Pi the modifier keys also work as expected in FreeCAD.

    P.S.: Unexpectedly 3D benchmark results are a lot better with the default [Removed] server than with NoMachine. (E.g. 3dmark2 results are < 100 for NoMachine and ~800 for [removed].) Subjectively FreeCAD works equally smooth for my simple models with both solutions, so I will likely continue to use NoMachine, which offers more options. Might be an indicator that there is room for improvement though 🙂

    P.P.S.: Got rid of the power warning (and black screen with  [removed]) when powering the Raspberry Pi from the iPad via USB cable (which is a neat mobile setup that extends the iPad with full Linux capabilities). The solution was to downclock and undervolt the Raspberry Pi.
    Perhaps one can get away with less downclocking (I essentially halfed the max frequencies) – just wanted to verify that I am turning on the right knob and that is conceptually solves the problem. FreeCAD is still fast enough in that setting though, so might leave it like this. Less power draw is also good for battery.
    People who already have a Raspberry Pi 4 and use it solely for their iPads probably don’t have to upgrade to a RPi 5. If one buys a new RPi anyways one can also get the Pi5 though. When downclocked for use as “co-processor” on the iPad it is still at least not slower than the Pi4. And it can be clocked up when a power plug outlet is within reach.

    Settings to downclock and undervolt the RPi in /boot/config.txt:
    # Tell the DVFS algorithm to increase voltage by this amount (in µV; default 0).
    over_voltage_delta=-10000

    # Set the Arm A76 core frequency (in MHz; default 2400).
    arm_freq=1200

    # Set the VideoCore VII core frequency (in MHz; default 800).
    gpu_freq=400

    #46918
    nannerbm
    Participant

    Hi – New here, old nomachine user.

    Just fired up my RPi5 … 8 Gig … using bookworm. I note the Wayland discussion above. … Could someone please post here the RPi ?4? packages to download and configure for the RPi 5 Bookworm? … I assume it is an ARMv8 package??

    Thx

    #46934
    Macrobiotic
    Participant

    Hi nannerbm,

    The closest you will get is the Raspberry Pi 4 installer for ARMv8 here: https://downloads.nomachine.com/linux/?id=29&distro=Raspberry

    However, there are two issues with the current implementation of NoMachine on RPi5.

    Firstly, the Raspberry Pi OS for Raspberry Pi 5 doesn’t let you install .deb packages using the GUI. Instead you need to use the command line.

    I think this is the article I used to guide me in installing .deb packages using the command line: https://askubuntu.com/questions/40779/how-do-i-install-a-deb-file-via-the-command-line

    Secondly, the current build of NoMachine doesn’t support Wayland compositors, and as far as I’ve gathered, you would need to switch to X11 instead of Wayland.

    There are posts above which go through how to make NoMachine work by switching to X11.

    Hope this helps.

     

    #46945
    Britgirl
    Participant

    Hi everyone,

    There are two issues with the current implementation of NoMachine on RPi5.

    Just so it’s clear what the situation is. The problem with RPi5 (not NoMachine) is that it lacks the capabilities of a full GUI (raspi-config app), so installing has to be done via the command line. This applies to any application you want to install, including, of course NoMachine. You can try installing with another graphical package manager.

    Secondly, the RPi5 has a small identity problem 🙂  If you run ‘uname -m’ to know what architecture it is, you get ‘aarch64’ as the output.  But there are 32-bit libraries installed there:

    file /bin/cat/bin/cat: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, BuildID[sha1]=ae08710495f166403a0b241bb0601fe595494e59, for GNU/Linux 3.2.0, stripped

    so you would need to install this:
    https://downloads.nomachine.com/download/?id=104&distro=Raspberry&hw=Pi4

    or this:
    https://downloads.nomachine.com/download/?id=109&distro=Raspberry&hw=Pi4

    Now to NoMachine – as I’ve mentioned before, there is a Trouble Report (see my post from earlier in the thread) which is related to the Wayland compositor. The workaround, which is temporary whilst our developers fix it, is to disable Wayland and use X.org.

    RaspberryPi OS:
    sudo raspi-config
    Advanced Options -> Wayland -> X11 -> OK -> Finish -> Yes (to reboot)
Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.