Remote virtual desktop does not resize in conjunction with certain client

Forum / General Discussions / Remote virtual desktop does not resize in conjunction with certain client

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #44275
    timo
    Participant

    Hi,

    connecting to a remote virtual desktop from my Windows 11 notebook
    comes with the issue that I wasn’t able to resize the remote desktop so far to my needs.

    It always reverts to this configuration with 1280×720 (see image)

    A bit suspicious already that it only offers me FHD max on a UHD system.

    Client: Notebook is a Ryzen APU with a UHD display, Windows 11, NoMachine Client v8.5.3
    Server: Subscribed Workstation (4x) v8.5.3, Fedora 38, SSH Tunnel

    Note 1: Another desktop with Win11, NM Client v.8.5.3 and a WQHD display works as expected
    connected to the very same server. There I can scale the remote desktop to the client native resolution
    of 2560 x 1440.

    Note 1: No regression. Same for v8.4.2.

    Thanks and br,
    Timo

    #44328
    timo
    Participant

    Found the time to compare against the WQHD setup.

    Seems like this has to do with scaling on HiDPI setups.
    The default puts the NM client window to a geometry of said 1280 x 720 px.
    Consequently, syncing the server’s desktop res fails to up that and provides just that.
    Fonts are visibly washed out, whereas on the WQHD it’s crisp.

    There are plenty of threads and help topics about that.
    Yet, all application specific steps I tried did not help.

    Only option that seems to have an effect for me at all is that one

    win11_hidpi_scaling_compat

    Then again everything gets very small.
    Up the scaling on the client does not help as it only allows going
    from 300 % (auto for that res) to 350 % max, besides being a global setting.

    Changing dpi on the server (Fedora 38, GNOME 4) came to my mind,
    but that ended up in a non-working state where the mapping from mouse to screen space
    seems to be off. (Wasn’t able to click buttons and fields anymore straightforward).

    Can someone confirm this on a Windows 11 UHD (4K) setup?
    Wonder if that’s only to do with the res (or better the actual dpi from the panel “driver”)
    or if that’s also dependent on the GPU driver, etc …

    As a workaround I’m now switching the display to FHD.
    But even than it only works with additionally setting the compat dialog as posted above.

    #44904
    Britgirl
    Participant

    A similar topic was posted here with the same workaround: https://forum.nomachine.com/topic/windows-display-scaling-nomachine-makes-it-blurry

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.